6 Replies Latest reply on Nov 14, 2012 7:45 PM by 973315

    OIM 11g R1 Creating an adapter task java code is not updated.

      I am trying to create an adapter task and I am having a problem with the java code. I tried both adding the jar to the javatasks folder and using upload/delete jars utility and am still having the same problem. The issue I have is that even though I am adding a new jar to the javatasks folder the adapter task is referencing the old classes that were used, which causes various errors like method not found. The steps I have taken are, delete the jar from javatasks folder,delete the adapter, Purge the cache, restart the server then put the jar back in java tasks and remake the adapter. I have also tried all the previous steps using upload jars, and renaming the jar and trying again. None have seemed to update the java code. I am also wondering why this thread was deleted, because his issue seemed similar to mine. https://forums.oracle.com/forums/thread.jspa?messageID=10682516&tstart=0

      I tried all the steps in that thread here is the google cache so you can look at it thanks.


      Lastly, the server is in production mode so I am aware that a restart might be needed, however I did not have problems in the past with updating adapters on the same server and did not need to restart when uploading scheduled tasks or event handlers.

      Edited by: 970312 on Nov 9, 2012 8:04 AM