This discussion is archived
4 Replies Latest reply: Nov 14, 2012 7:18 AM by Alan_S RSS

Update to 11.1 - "No solution was found to satisfy constraints"

user2083879 Newbie
Currently Being Moderated
I'm trying to update a T4-2 from S11 SRU 10.5 to 11.1, and I'm getting some sort of horrible dependency errors that I don't know where to begin to diagnose. Any advice of where to start looking would be greatly appreciated.

(N.b. from a couple of experiments, I seem to get a similar set of errors when I try to install or uninstall any package. I'm starting to wonder whether the SRU10.5 patch went a bit pear-shaped somehow)

root@beta:/var/tmp/stb/extract# pkg list entire
NAME (PUBLISHER) VERSION IFO
entire 0.5.11-0.175.0.10.0.5.0 i--
root@beta:/var/tmp/stb/extract# pkg publisher
PUBLISHER TYPE STATUS URI
solaris origin online https://pkg.oracle.com/solaris/support/
oraddt origin online file:///var/tmp/stb/extract/ipsrepo/
root@beta:/var/tmp/stb/extract# pkg update --accept
Creating Plan |
pkg update: No solution was found to satisfy constraints

maintained incorporations:

pkg://solaris/consolidation/ldoms/ldoms-incorporation@0.5.11,5.11-0.175.0.8.0.3.0:20120525T222045Z
pkg://solaris/consolidation/gfx/gfx-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144752Z
pkg://solaris/consolidation/vpanels/vpanels-incorporation@0.5.11,5.11-0.175.0.0.0.1.778:20111012T230640Z
pkg://solaris/consolidation/admin/admin-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
pkg://solaris/consolidation/SunVTS/SunVTS-incorporation@0.5.11,5.11-0.175.0.7.0.3.0:20120421T004225Z
pkg://solaris/consolidation/solaris_re/solaris_re-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T122734Z
pkg://solaris/consolidation/cacao/cacao-incorporation@0.5.11,5.11-0.175.0.6.0.1.0:20120323T204721Z
pkg://solaris/consolidation/jdmk/jdmk-incorporation@0.5.11,5.11-0.173.0.0.0.0.0:20110828T210111Z
pkg://solaris/consolidation/dbtg/dbtg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144751Z
pkg://solaris/consolidation/ips/ips-incorporation@0.5.11,5.11-0.175.0.10.0.4.0:20120731T142249Z
pkg://solaris/consolidation/cde/cde-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T191905Z
pkg://solaris/consolidation/smcc/smcc-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144755Z
pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.10.0.5.1:20120803T181010Z
pkg://solaris/consolidation/man/man-incorporation@0.5.11,5.11-0.175.0.0.0.0.0:20110927T192523Z
pkg://solaris/consolidation/desktop/desktop-incorporation@0.5.11,5.11-0.175.0.10.0.4.0:20120731T141828Z
pkg://solaris/consolidation/l10n/l10n-incorporation@0.5.11,5.11-0.175.0.9.0.1.107:20120612T195416Z
pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.10.0.2.1231:20120716T221822Z
pkg://solaris/consolidation/sic_team/sic_team-incorporation@0.5.11,5.11-0.172.0.0.0.0.0:20110816T070737Z
pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.174.0.0.0.0.0:20110921T184135Z
pkg://solaris/entire@0.5.11,5.11-0.175.0.10.0.5.0:20120803T182627Z
pkg://solaris/consolidation/cns/cns-incorporation@0.5.11,5.11-0.175.0.10.0.4.0:20120731T142644Z
pkg://solaris/consolidation/nspg/nspg-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144753Z
pkg://solaris/consolidation/install/install-incorporation@0.5.11,5.11-0.175.0.10.0.4.0:20120731T141438Z
pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.0.10.0.5.0:20120803T181731Z
pkg://solaris/consolidation/desktop/gnome-incorporation@0.5.11,5.11-0.175.0.10.0.4.0:20120731T141829Z
pkg://solaris/consolidation/sfw/sfw-incorporation@0.5.11,5.11-0.175.0.0.0.2.0:20111019T144754Z

Plan Creation: dependency error(s) in proposed packages:

No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.8:20110620T221620Z found:
Reject: pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.8:20110620T221620Z
Reason: All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete
No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.3:20110121T162616Z found:
Reject: pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1.3:20110121T162616Z
Reason: All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete
No suitable version of required package pkg://solaris/shell/ksh93@93.21.0.20110208,5.11-0.175.1.0.0.24.0:20120904T174231Z found:
Reject: pkg://solaris/shell/ksh93@93.21.0.20110208,5.11-0.175.1.0.0.24.0:20120904T174231Z
Reason: All versions matching 'require' dependency pkg:/system/library/math@0.5.11,5.11-0.175.1.0.0.19.0 are rejected
Reject: pkg://solaris/system/library/math@0.5.11,5.11-0.175.1.0.0.19.0:20120625T151932Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/sunpro/sunpro-incorporation@0.5.11,5.11-0.174.0.0.0.0.0:20110921T184135Z
No suitable version of required package pkg://solaris/developer/versioning/mercurial-26@2.2.1,5.11-0.175.1.0.0.24.0:20120904T171728Z found:
Reject: pkg://solaris/developer/versioning/mercurial-26@2.2.1,5.11-0.175.1.0.0.24.0:20120904T171728Z
Reason: All versions matching 'require' dependency pkg:/system/library@0.5.11,5.11-0.175.1.0.0.23.0 are rejected
Reject: pkg://solaris/system/library@0.5.11,5.11-0.175.1.0.0.24.2:20120919T185104Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.10.0.5.1:20120803T181010Z
No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1:20101104T230755Z found:
Reject: pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1:20101104T230755Z
Reason: All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete
No suitable version of required package pkg://solaris/system/input-method/iiim-xim@0.5.11,5.11-0.175.1.0.0.23.1134:20120820T155226Z found:
Reject: pkg://solaris/system/input-method/iiim-xim@0.5.11,5.11-0.175.1.0.0.23.1134:20120820T155226Z
Reason: All versions matching 'require' dependency pkg:/x11/library/libx11@1.5.0,5.11-0.175.1.0.0.20.1309 are rejected
Reject: pkg://solaris/x11/library/libx11@1.5.0,5.11-0.175.1.0.0.24.1317:20120904T175954Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.10.0.2.1231:20120716T221822Z
No suitable version of required package pkg://solaris/system/library/iconv/unicode-core@0.5.11,5.11-0.175.1.0.0.23.1134:20120820T155553Z found:
Reject: pkg://solaris/system/library/iconv/unicode-core@0.5.11,5.11-0.175.1.0.0.23.1134:20120820T155553Z
Reason: All versions matching 'require' dependency pkg:/system/library@0.5.11,5.11-0.175.1.0.0.20.0 are rejected
Reject: pkg://solaris/system/library@0.5.11,5.11-0.175.1.0.0.24.2:20120919T185104Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.10.0.5.1:20120803T181010Z
No suitable version of required package pkg://solaris/driver/network/ethernet/elxl@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184308Z found:
Reject: pkg://solaris/driver/network/ethernet/elxl@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184308Z
Reason: All versions matching 'require' dependency pkg:/system/kernel@0.5.11,5.11-0.175.1.0.0.24.2 are rejected
Reject: pkg://solaris/system/kernel@0.5.11,5.11-0.175.1.0.0.24.2:20120919T185011Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.10.0.5.1:20120803T181010Z
No suitable version of required package pkg://solaris/x11/server/xorg/driver/xorg-video-mga@1.5.0,5.11-0.175.1.0.0.24.1317:20120904T180053Z found:
Reject: pkg://solaris/x11/server/xorg/driver/xorg-video-mga@1.5.0,5.11-0.175.1.0.0.24.1317:20120904T180053Z
Reason: All versions matching 'require' dependency pkg:/diagnostic/scanpci@0.13.1,5.11-0.175.1.0.0.24.1317 are rejected
Reject: pkg://solaris/diagnostic/scanpci@0.13.1,5.11-0.175.1.0.0.24.1317:20120904T175806Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.10.0.2.1231:20120716T221822Z
No suitable version of required package pkg://solaris/system/graphics/fbconfig/fbconfig-mga@0.5.11,5.11-0.175.1.0.0.24.1317:20120904T175918Z found:
Reject: pkg://solaris/system/graphics/fbconfig/fbconfig-mga@0.5.11,5.11-0.175.1.0.0.24.1317:20120904T175918Z
Reason: All versions matching 'require' dependency pkg:/system/graphics/fbconfig@0.5.11,5.11-0.175.1.0.0.24.1317 are rejected
Reject: pkg://solaris/system/graphics/fbconfig@0.5.11,5.11-0.175.1.0.0.24.1317:20120904T175919Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/X/X-incorporation@0.5.11,5.11-0.175.0.10.0.2.1231:20120716T221822Z
No suitable version of required package pkg://solaris/developer/opensolaris/X@0.5.11,5.11-0.175.1.0.0.24.1317:20120904T175805Z found:
Reject: pkg://solaris/developer/opensolaris/X@0.5.11,5.11-0.175.1.0.0.24.1317:20120904T175805Z
Reason: All versions matching 'require' dependency pkg:/developer/build/libtool@2.2.2,5.11 are rejected
Reject: pkg://solaris/developer/build/libtool@2.4.2,5.11-0.175.1.0.0.24.0:20120904T171232Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/userland/userland-incorporation@0.5.11,5.11-0.175.0.10.0.5.0:20120803T181731Z
No suitable version of required package pkg://solaris/driver/network/ethernet/dnet@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184307Z found:
Reject: pkg://solaris/driver/network/ethernet/dnet@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184307Z
Reason: All versions matching 'require' dependency pkg:/system/kernel@0.5.11,5.11-0.175.1.0.0.24.2 are rejected
Reject: pkg://solaris/system/kernel@0.5.11,5.11-0.175.1.0.0.24.2:20120919T185011Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.10.0.5.1:20120803T181010Z
No suitable version of required package pkg://solaris/driver/network/ethernet/iprb@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184311Z found:
Reject: pkg://solaris/driver/network/ethernet/iprb@0.5.11,5.11-0.175.1.0.0.24.2:20120919T184311Z
Reason: All versions matching 'require' dependency pkg:/system/kernel@0.5.11,5.11-0.175.1.0.0.24.2 are rejected
Reject: pkg://solaris/system/kernel@0.5.11,5.11-0.175.1.0.0.24.2:20120919T185011Z
Reason: This version is excluded by installed incorporation pkg://solaris/consolidation/osnet/osnet-incorporation@0.5.11,5.11-0.175.0.10.0.5.1:20120803T181010Z
  • 1. Re: Update to 11.1 - "No solution was found to satisfy constraints"
    Alan_S Explorer
    Currently Being Moderated
    solaris origin online https://pkg.oracle.com/solaris/support/
    oraddt origin online file:///var/tmp/stb/extract/ipsrepo/

    I think your problem may be related to to oraddt publisher. If it contains packages that have older dependencies, it may not be met by the support repo:

    No suitable version of required package pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1:20101104T230755Z found:
    Reject: pkg://solaris/developer/build/onbld@0.5.11,5.11-0.151.0.1:20101104T230755Z
    Reason: All acceptable versions of 'require' dependency on pkg:/runtime/python-24 are obsolete

    Try first disabling your oraddt publisher, and see if the results are better.

    -- Alan
  • 2. Re: Update to 11.1 - "No solution was found to satisfy constraints"
    user2083879 Newbie
    Currently Being Moderated
    The oraddt repository is only there from when I tried to install Explorer manually, after the "install_stb.sh" script didn't work. I have also tried upgrades without it present and get the same list of errors. I seem to get errors with any package install/update/uninstall commands after the SRU 10.5 update on this server.

    I've rolled the server back to a SRU9.5 boot environment that I know works. I have another server that I could upgrade successfully, and so I'm trying the blunt instrument of "remove all packages on the failing server that weren't on the successfully-upgraded one, then re-upgrade and hope for the best."

    Are there any guides on troubleshooting IPS, or at least getting useful information out of it about why it's rejected packages? In my experience of investigating this, the different verbosity levels on pkg update went something like "-v - no additional info. -vv - no additional info. -vvv - so much output my brain melts, but none of it comprehensible."
  • 3. Re: Update to 11.1 - "No solution was found to satisfy constraints"
    user2083879 Newbie
    Currently Being Moderated
    Well, it looks like the "blunt instrument" solution has worked - I removed the following list of packages from the failing T4-2 (all the packages that were not installed on the other T4-2 that upgraded successfully) and after doing that, I could upgrade to SRU10.5 and then 11.1 successfully.

    benchmark/x11perf
    compatibility/packages/SUNWbip
    compatibility/packages/SUNWxwplt
    consolidation/nvidia/nvidia-incorporation
    developer/gnu-binutils
    developer/library/lint
    driver/x11/xsvc
    library/motif
    library/perl-5/xml-parser-584
    runtime/perl-584
    runtime/perl-584/extra
    system/header
    system/library/gcc-45-runtime
    system/management/hmp/hmp-tools
    x11/compatibility/links-svid
    x11/library/dps
    x11/library/libxevie
    x11/library/libxvmc
    x11/library/toolkit/libxaw4
    x11/library/toolkit/libxaw5
    x11/library/xtrans

    Not sure which one of these caused the upgrade problem though.
  • 4. Re: Update to 11.1 - "No solution was found to satisfy constraints"
    Alan_S Explorer
    Currently Being Moderated
    Sorry, I missed the fact that this was a SPARC system and had the nvidia incorporation installed. It should have been removed when you updated to SRU 10, but apparently it lingered. See the "How to Update to 11.1" document, where it mentions the steps that are needed to update a system running this SRU. I think the step that was missed might have been:

    Update the IPS package itself:
    # pkg update pkg:/package/pkg

    -- Alan

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points