9 Replies Latest reply: Jan 18, 2013 5:17 PM by 960529 RSS

    BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up

    960529
      After upgrading to OIM BP04, I following the readme to install BI Publishing, but used the 11.1.1.6.0 version.

      After creating: C:\Oracle\Middleware\Oracle_BIP\user_projects\domains\bifoundation_domain\config\bipublisher\repository\Reports\Oracle Identity Manager
      I copied C:\Oracle\Middleware\Oracle_BIP\user_projects\domains\bifoundation_domain\config\bipublisher\repository\Reports\Oracle Identity Manager\OIM_11gR1_BIP11gReports.zip and uncompressed it here..
      Then I restarted everything except for the database.

      When I logon to the BIP console, go to Catalog then Shared Folders, there is no 'Oracle Identity Manager' folder...only the original Components and Sample folders.

      What's up with that?
        • 1. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
          Karthik Perath
          You need to extra configuration in BI admin UI. Check this link for more details
          BI Publisher 11.1.1.6 with OIM 11gR2
          • 2. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
            960529
            Thanks. No need to apply the patch, completing the update process in the admin ui resolves the issue.

            However, when I try to run a report, the default data source has to be edited...I change to valid/tested data source and hit save, the admin ui sits there 'saving' and never completes...thoughts?
            I have restarted wl/soa/oim/bip...but not the oracle database.
            • 3. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
              960529
              While I still can't save the 'default data setting' value for the job....any ideas?


              I noticed the available patches can only be applied if ENTERPRISE had been installed...are there different patches if 'SIMPLE INSTALLATION' was done?
              • 4. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
                960529
                Note to self...when creating the jdbc connection, you HAVE to use the name 'OIM JDBC' ... I was using a different name:

                Data Source Name OIM JDBC
                Connection String jdbc:oracle:thin:@host:port:sid
                Username Username for a database schema user that has access to Oracle Identity Manager.
                Password Password for user identified in the Username field.
                Database Drive Class oracle.jdbc.driver.OracleDriver

                And when you select create new jdbc connection, the default database drive class is different from the instructions above.


                After making these changes, any new OIM report automatically used the OIM JDBC data source. Although, if I make a change to a report's properties/settings, it again goes into a saving hang state.

                Plus, when I click 'Get XML Output' none of the reports produce any data...thoughts?
                • 5. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
                  960529
                  Anyone seen this error...getting it from Organizationa Details.xdo...when searching on any existing organization in OIM?

                  Error
                  The report cannot be rendered because of an error, please contact the administrator.
                  Error Detail


                  oracle.xdo.XDOException: oracle.xdo.XDOException: oracle.xdo.XDOException: java.sql.SQLSyntaxErrorException: ORA-00923: FROM keyword not found where expected
                  • 6. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
                    960529
                    After applying p14088000 of BIP 11.1.1.6.0 on top of OIM 11.1.1.5.4, the reports and EM started working. I realize tihs configuration is not certified...and I may revert to BIP 11.1.1.5.0 which is certified on OIM 11.1.1.5.4.

                    Has anyone got an OIM report working that shows all the OIM Identities pulled from a resource on a specific day/range?

                    Special thanks to Kevin for pointing out that date fields must be populated.
                    • 7. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
                      960529
                      I rolled back bip 11.1.1.6 and installed 11.1.1.5.3 and setup the OIM 11.1.1.5.4 reports shipped with BP04. The data source and reports are setup.
                      However, none of the Role or Resource reports bring any data into the reports, where all the User reports work fine.

                      Anyone find the reason why OOTB OIM BP04 Role/Resource reports do not produce any data?

                      For example, running the user report shows users with the AD User resource assigned, yet running the Resource report return No Data.
                      • 8. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
                        960529
                        Anyone with BIP 11.1.1.5.3 running with OIM 11.1.1.5.4 OIM reports have the Resource and Role reports working?

                        All the user reports work.

                        When I run any filter combination, no data is returned.

                        One issue is that the lookup table for the DBUM Role was successfully built, however, the UD_DB_ORA_R table is empty, I thought that was supposed to contain the roles from the lookup definition.
                        • 9. Re: BI Publisher 11g 11.1.1.6.0 and OIM Reports Not Showing Up
                          960529
                          The answer is to open up the weblogic security schema for BIP and add a user account with the same name used to access OIM, then add the BI_Authors role. Save. Restart BIP. This got me the Resource Reports.

                          The DB Roles and Privs reports still don't work OOTB because the jobs don't update the UD_DB_ORA_P and _R tables. Still working on how to get that down. What's that...you know how...please do tell. Thanks :)