1 Reply Latest reply: Nov 12, 2012 4:38 AM by Pgleghorn-Oracle RSS

    Webcenter Site 11g : Cluster Install : logout issue facing.

    973628
      Hi Friends ,

      We have installed the Webcenter site 11g Cluster install on Weblogic server successfully. We have faced any issues while installation. After successful installtion , When we login to sample sites( going here & then) and click on the LOGOUT button on the page , its not logging out , again it is landing with same page where we clicked LOGOUT button.

      We shutdown one cluster server (NODE1) , and NODE2 was up and running , now logout issue is not persisting and same NODE2 was down and NODE1 was up , now also no issue. BUT , if we start accessing sites from LBR url , this logout issue facing. There is no Error in sites..log & cas.log.

      :-( we have created the ORacle SR , but still we have not received any soln.

      Please help us , what could be the issue here.


      Naveen
        • 1. Re: Webcenter Site 11g : Cluster Install : logout issue facing.
          Pgleghorn-Oracle
          It's possible this is due to the cas url not being set correctly. In SSOConfig.xml you have two places to set this

          casUrl - needs to be set to the external address for cas, this link will be included in pages visible to the end user (eg via webserver or loadbalancer).
          casInternalUrl - needs to be set to an internal address for cas, Sites/CS will call this directly (should not go through webserver/loadbalancer)

          If these are correct, then try to rule out whether the webserver/loadbalancer is an issue
          - is it session sticky?
          - if you set casUrl / casInternalUrl to point direct to cas can you login/logout direct to CS without the loadbalancer?

          Phil