This discussion is archived
1 Reply Latest reply: Nov 12, 2012 7:26 PM by Kalyan Pasupuleti-Oracle RSS

OSB console locked while changing Admin Server system password

Bhaskar Newbie
Currently Being Moderated
Hi All,



Hope you are doing good.



We have clusted environmemt running on Weblogic 10.3.5 and OSb 11.1.1.5 . It consists of AS and 2 MS in a distributed environment (3 machines). All are under NM control. I have tried to change the Weblogic administrator password, it got changed successfully but after chaning it I can't login to OSB console. It is throwing error for Authentication Denied.

Steps I follwed to change the admin password for Weblogic system user


STEP1:

cd $DOMAIN_HOME/bin

. ./setDomainEnv.sh


STEP 2:

cd ../security

mv DefaultAuthenticatorInit.ldift oldDefaultAuthenticator

java weblogic.security.utils.AdminAccount weblogic mynewpassword .


STEP 3:

cd .../servers/AdminServer

mv data data_old

cd security/

mv boot.properties oldboot.properties

Create new boot.properties file with new credentials


STEP 4:

cd $DOMAIN_HOME/bin

./startWebLogic.sh



After server restart AdminServer logs started throwing error:



<Nov 12, 2012 3:00:19 PM GMT> <Error> <Deployer> <BEA-149205> *<Failed to initialize the application 'ALSB Framework Starter A*

pplication' due to error java.lang.RuntimeException: OSB system user authentication failed.

java.lang.RuntimeException: OSB system user authentication failed

at com.bea.wli.sb.security.SecurityModuleImpl.runAlsbPrivilegedAction(SecurityModuleImpl.java:340)

at com.bea.wli.sb.security.SecurityModuleImpl.jndiBind(SecurityModuleImpl.java:411)

at com.bea.alsb.platform.weblogic.WlsJNDIService.bind(WlsJNDIService.java:42)

at com.bea.wli.sb.init.FrameworkStarter$ALSBClusterTimerJndiAccess.bindClusterTimer(FrameworkStarter.java:372)

at com.bea.wli.timer.ClusterTimerService.initialize(ClusterTimerService.java:86)

Truncated. see log file for complete stacktrace

Caused By: java.lang.RuntimeException: OSB system user authentication failed

at com.bea.wli.sb.security.SecurityModuleImpl.runAlsbPrivilegedAction(SecurityModuleImpl.java:340)

at com.bea.wli.sb.security.SecurityModuleImpl.jndiBind(SecurityModuleImpl.java:411)

at com.bea.alsb.platform.weblogic.WlsJNDIService.bind(WlsJNDIService.java:42)

at com.bea.wli.sb.init.FrameworkStarter$ALSBClusterTimerJndiAccess.bindClusterTimer(FrameworkStarter.java:372)

at com.bea.wli.timer.ClusterTimerService.initialize(ClusterTimerService.java:86)

Truncated. see log file for complete stacktrace

>

<Nov 12, 2012 3:00:57 PM GMT> <Warning> <J2EE> <BEA-160195> <The application version lifecycle event listener oracle.security

.jps.wls.listeners.JpsAppVersionLifecycleListener is ignored because the application em is not versioned.>

[ERROR] AdapterManager - ServletContainerAdapter manager not initialized correctly.

<Nov 12, 2012 3:01:53 PM GMT> <Error> <Deployer> <BEA-149231> <*Unable to set the activation state to true for the application*

*'XBus Kernel'.*

java.lang.NullPointerException

at com.bea.wli.config.ConfigService.startListeners(ConfigService.java:984)

at com.bea.wli.sb.init.AppListener.__postStart(AppListener.java:424)

at com.bea.wli.sb.init.AppListener.access$200(AppListener.java:106)

at com.bea.wli.sb.init.AppListener$4.run(AppListener.java:385)

at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)

Truncated. see log file for complete stacktrace

Caused By: java.lang.NullPointerException

at com.bea.wli.config.ConfigService.startListeners(ConfigService.java:984)

at com.bea.wli.sb.init.AppListener.__postStart(AppListener.java:424)

at com.bea.wli.sb.init.AppListener.access$200(AppListener.java:106)

at com.bea.wli.sb.init.AppListener$4.run(AppListener.java:385)

at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:363)

Truncated. see log file for complete stacktrace

>

<Nov 12, 2012 3:01:54 PM GMT> <Warning> <ConfigFwk> <BEA-000000> <Setting transaction '2' as rollback only. Rollback reason:

java.lang.NullPointerException

at com.bea.wli.config.component.impl.SimpleTypeImpl.<init>(SimpleTypeImpl.java:101)

at com.bea.wli.sb.uddi.auto.UDDIAutoImportStateManager$1.execute(UDDIAutoImportStateManager.java:156)

at com.bea.wli.config.transaction.TransactionalTask._doExecute(TransactionalTask.java:217)

at com.bea.wli.config.transaction.TransactionalTask.doExecute(TransactionalTask.java:140)

at com.bea.wli.sb.uddi.auto.UDDIAutoImportStateManager.<init>(UDDIAutoImportStateManager.java:164)

Truncated. see log file for complete stacktrace

>

<Nov 12, 2012 3:01:54 PM GMT> <Error> <Deployer> <BEA-149231> <Unable to set the activation state to true for the application

'ALSB UDDI Manager'.

java.lang.NullPointerException

at com.bea.wli.config.component.impl.SimpleTypeImpl.<init>(SimpleTypeImpl.java:101)

at com.bea.wli.sb.uddi.auto.UDDIAutoImportStateManager$1.execute(UDDIAutoImportStateManager.java:156)

at com.bea.wli.config.transaction.TransactionalTask._doExecute(TransactionalTask.java:217)

at com.bea.wli.config.transaction.TransactionalTask.doExecute(TransactionalTask.java:140)

at com.bea.wli.sb.uddi.auto.UDDIAutoImportStateManager.<init>(UDDIAutoImportStateManager.java:164)

Truncated. see log file for complete stacktrace

Caused By: java.lang.NullPointerException

at com.bea.wli.config.component.impl.SimpleTypeImpl.<init>(SimpleTypeImpl.java:101)

at com.bea.wli.sb.uddi.auto.UDDIAutoImportStateManager$1.execute(UDDIAutoImportStateManager.java:156)

at com.bea.wli.config.transaction.TransactionalTask._doExecute(TransactionalTask.java:217)

at com.bea.wli.config.transaction.TransactionalTask.doExecute(TransactionalTask.java:140)

at com.bea.wli.sb.uddi.auto.UDDIAutoImportStateManager.<init>(UDDIAutoImportStateManager.java:164)

Truncated. see log file for complete stacktrace

OSB console is not accepting the credential, however I can login to EM console and ADMIN console. I am not sure how OSB maintains any internal user to communicate with weblogic domain, which has not automatically propagated. I have changed the password using console and re-started AdminSever but no luck! What step is left/wrongly exceuted?


Any help really appreciated!

Thanks in advance!

Bhaskar

Edited by: Bhaskar on 12-Nov-2012 11:50

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points