0 Replies Latest reply: Nov 13, 2012 9:11 AM by ckrig-Oracle RSS

    em says "Unable to retrieve composite details" for soa-infra deployed app

    ckrig-Oracle
      WLS 11.1.1.5, two node cluster running on AIX

      One of five deployments give below error message when clicking on Farm_bpm_domain/SOA/soa-infra/mydomain/myapp

      Same deployed composite shows red "Target not found" under Farm_bpm_domain/SOA/soa-infra under Deployed Composites

      This seems to be unrelated to bug 13387571 (SSL), and the "java.lang.NullPointerException" is probably of relevance (have seen other, also unrelated, reports with "java.lang.RuntimeException" instead).

      WLS_SOA?-diagnostic.log shows nothing out of the ordinary, no errors.

      Four of five apps are fine so no general problem with the cluster.

      Any suggestion where to start looking?

      Thanks,
      --cb


      ERROR POPUP
      =========
      Unable to retrieve composite details.
      Error retrieving Composite DequeueVehicleRotations (2.0) details from soa-infra runtime. This could happen due to the errors in soa-infra initialization. Please view the log files for details.
      EJB Exception: ; nested exception is:
      java.lang.NullPointerException
      ...
      oracle.sysman.emSDK.app.exception.EMSystemException at oracle.sysman.emai.model.sca.composite.core.impl.EMCompositeModel.handleError(EMCompositeModel.java:72) at oracle.sysman.emai.model.sca.share.composite.CompositeCoreModel.initialize(CompositeCoreModel.java:106) at oracle.sysman.emai.model.sca.composite.core.impl.CompositeModel.initialize(CompositeModel.java:46) at
      ...