2 Replies Latest reply on Nov 14, 2012 5:55 PM by cantfindausername

    Issues switching from non-versioned to versioned deployment


      I am trying to switch an ear application from non-versioned to versioned, and am running into issues with it.

      I have a clustered environment with 2 managed servers in my domain. The application is currently deployed as non-versioned. To change it to versioned, I edited the build script to include the "Weblogic-Application-version" tag in the MANIFEST.

      In order to deploy this versioned application, I first have to undeploy the old non-versioned application. So this is what I did:

      1) Shut down the application.
      2) Delete it.
      3) Deploy versioned ear.

      I ran into an issue which is described in this thread: Re: wlst deploy via ant fails with NameNotFoundException

      The versioned application is not getting picked up right away. It is set to "prepared" state. When I look at the managed servers, I see that the stage directory has a directory for the application, but nothing underneath it. However, the tmp/_WL_user directory contains the application, with a subdirectory with the version number, and the ear contained in it. When I bounce the managed servers, the ear gets copied from tmp/_WL_user to stage/, and the application is set to "Active".

      Why is this happening? Why can I not switch from non-versioned to versioned deployment without bouncing the managed servers?

      The suggested workaround in the above linked thread was to use "weblogic.jndi.retainenvionment" and set that to true in the server start script. That did not solve the problem.

      I was wondering if there is anything else that can be tried out to avoid the naming exceptions and the restart.