This content has been marked as final. Show 1 reply
You can not run JRE 1.7 on RHEL 3.8 or 4.6. They are too old.
There's no "backward compatibility of OS support matrix". The support matrix shows you the minimum versions that you need to use.
The minimum version for JRE 1.7 on RHEL is RHEL 5.5
Thus, you must use RHEL 5.5+
This is because your glibc doesn't have GLIBC_2.4 symbols - as you can see per your error message.
If you run Java 1.7 with glibc 2.4 or higher - then it will work.
Again, this is the minimum version, and you can run with newer as well.
This is not an issue for 1.7 support, because 1.7 is only supported on RHEL 5.5 or later.
You can either
1) Upgrade your OS
2) Stay on Java 6 - which uses an older glibc.
You can see on
That Java 6 is supported on RHEL 3 and RHEL 4.
Java 7 is not.
Edited by: user12611932 on Dec 17, 2012 11:26 AM