This discussion is archived
1 Reply Latest reply: Dec 17, 2012 11:26 AM by 826344 RSS

Upgrade of JRE from JRE1.6 U24 JRE1.7 U7, we are undergoing some issues in

881208 Newbie
Currently Being Moderated
1.     When we try to upgrade our JRE from JRE1.6 U24 JRE1.7 U7, we are undergoing some issues in Linux platforms.
2.     The OS from where we are trying to upgrade JRE is RHEL 3.8 – 32 bit and RHEL 4.6 – 64 bit
3.     Is there any limitation with JRE1.7 OS support?
4.     Did we break the backward compatibility of OS support matrix when we upgraded to JRE1.7?

When we execute the java in RHEL3.8 and RHEL 4.6 we are seeing the below error message

./java -version
Error: dl failure on line 864
Error: failed /usr/local/MegaRAID Storage Manager/jre/lib/i386/client/libjvm.so, because /lib/tls/libc.so.6: version `GLIBC_2.4' not found (required by /usr/local/MegaRAID Storage Manager/jre/lib/i386/client/libjvm.so)

Please let us know why are we experiencing the above issue and the root cause for this issue. From the OS support matrix:http://www.oracle.com/technetwork/java/javase/config-417990.html
we see nothing w.r.t. RHEL 3.8 or 4.6.

What we understood from the above link is if user wants to upgrade to JRE1.7.x, we are expecting him to give away the backward compatibility of OS support?
If my understanding is correct, wont this be an issue from JRE1.7.x support front?
  • 1. Re: Upgrade of JRE from JRE1.6 U24 JRE1.7 U7, we are undergoing some issues in
    826344 Newbie
    Currently Being Moderated
    Hi

    You can not run JRE 1.7 on RHEL 3.8 or 4.6. They are too old.
    There's no "backward compatibility of OS support matrix". The support matrix shows you the minimum versions that you need to use.
    The minimum version for JRE 1.7 on RHEL is RHEL 5.5

    Thus, you must use RHEL 5.5+

    This is because your glibc doesn't have GLIBC_2.4 symbols - as you can see per your error message.
    If you run Java 1.7 with glibc 2.4 or higher - then it will work.

    Again, this is the minimum version, and you can run with newer as well.

    This is not an issue for 1.7 support, because 1.7 is only supported on RHEL 5.5 or later.

    You can either
    1) Upgrade your OS
    2) Stay on Java 6 - which uses an older glibc.
    You can see on
    http://www.oracle.com/technetwork/java/javase/system-configurations-135212.html

    That Java 6 is supported on RHEL 3 and RHEL 4.
    Java 7 is not.

    Edited by: user12611932 on Dec 17, 2012 11:26 AM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points