2 Replies Latest reply on Nov 15, 2012 4:31 PM by 922185

    Submit Data via SmartView form - No message displayed on ???

      We just upgraded to and I found that no message is displayed at all when you hit "Submit Data" on the SmartView form. The business rule did run behind the scene. On our 9.3.1 verison, you will get a window prompt out with the business rule name, then a bar saying Form Saved, finally a message indicating the Data was successfully saved.

      Why are we not having anything on ? Help please!
        • 1. Re: Submit Data via SmartView form - No message displayed on ???

          There are probably some more flashy ways of doing this that I am not aware of.....

          However to know if data is submitted or not, we just use the cell colour formatting of dirty (un-submitted) cells and those that have been submitted (ie when you input a figure the cell changes colour, when you submit, the cell changes back to original colour). You can find this within Options on your SmartView tab in Excel.

          For a business rule (again this might be a little long winded and over complicated), but you could amend your business rule to include a run time prompt (set with the required default and no other options bar that member possible). You can then edit the webform, go to the business rule tab and properties, and then ensure the 'hide prompt' is not ticked - this will bring up the run time prompt upon save and let users know when the data has saved and rule has ran....

          1 person found this helpful
          • 2. Re: Submit Data via SmartView form - No message displayed on ???
            Thank you for the hint!

            On 9.3.1, we have the "Hide Prompt" checked on web forms. But we still get "Data Submitted" message and "Form being saved" bar.

            On, I tried de-selecting the option "Hide Prompt". Now I got a prompt for business rule running. The risk is that now the POV is open. Users can modify the POV before running the business rule. Is there a way to disable the POV selection?

            Is there a setting that's different between the 2 versions which might cause the different behavior ?