0 Replies Latest reply: Nov 15, 2012 5:04 AM by 912607 RSS

    weblogic crash in deployment NoClassDefFoundError

    912607
      Hi Guys

      could you please tell me how can this be fixed ?

      i use to get this exception when i deploy my project within Eclipse:

      java.lang.NoClassDefFoundError: javax/faces/component/UIComponentBase.

      here's a pastebin related to the full exception :

      http://pastebin.com/7fTHznnz


      i'm using weblogic 10.3.6.

      jre 1.6

      jdk 1.6

      eclipse 3.8


      and here's starting log related to the weblogic in eclipse:

      JAVA Memory arguments: -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=48m -XX:MaxPermSize=128m
      .
      WLS Start Mode=Development
      .
      CLASSPATH=c:\PROGRA~2\Java\JDK16~1.0_3\lib\tools.jar;C:\CONTAI~1\weblogic\wlserver\server\lib\weblogic_sp.jar;C:\CONTAI~1\weblogic\wlserver\server\lib\weblogic.jar;C:\CONTAI~1\weblogic\modules\features\weblogic.server.modules_10.3.6.0.jar;C:\CONTAI~1\weblogic\wlserver\server\lib\webservices.jar;C:\CONTAI~1\weblogic\modules\ORGAPA~1.1/lib/ant-all.jar;C:\CONTAI~1\weblogic\modules\NETSFA~1.0_1/lib/ant-contrib.jar;C:\CONTAI~1\weblogic\wlserver\common\derby\lib\derbyclient.jar;C:\CONTAI~1\weblogic\wlserver\server\lib\xqrl.jar;C:\rims\iRIMS\Libraries\common\commons-logging-1.0.4.jar
      .
      PATH=;C:\CONTAI~1\weblogic\wlserver\server\native\win\32;C:\CONTAI~1\weblogic\wlserver\server\bin;C:\CONTAI~1\weblogic\modules\ORGAPA~1.1\bin;c:\PROGRA~2\Java\JDK16~1.0_3\jre\bin;c:\PROGRA~2\Java\JDK16~1.0_3\bin;C:/Program Files (x86)/Java/jre6/bin/client;C:/Program Files (x86)/Java/jre6/bin;C:/Program Files (x86)/Java/jre6/lib/i386;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\oraclexe\app\oracle\product\11.2.0\server\bin;;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Intel\DMIX;C:\Program Files (x86)\Windows Live\Shared;%JAVA_HOME%/bin;C:\Program Files (x86)\CVSNT\;C:\eclipse;;C:\CONTAI~1\weblogic\wlserver\server\native\win\32\oci920_8
      .
      ***************************************************
      * To start WebLogic Server, use a username and *
      * password assigned to an admin-level user. For *
      * server administration, use the WebLogic Server *
      * console at http:\\hostname:port\console *
      ***************************************************
      starting weblogic with Java version:
      java version "1.6.0_37"
      Java(TM) SE Runtime Environment (build 1.6.0_37-b06)
      Java HotSpot(TM) Client VM (build 20.12-b01, mixed mode, sharing)
      Starting WLS with line:
      c:\PROGRA~2\Java\JDK16~1.0_3\bin\java -client -Xms256m -Xmx512m -XX:CompileThreshold=8000 -XX:PermSize=48m -XX:MaxPermSize=128m -Dweblogic.Name=myserver -Djava.security.policy=C:\CONTAI~1\weblogic\wlserver\server\lib\weblogic.policy -Xverify:none -da -Dplatform.home=C:\CONTAI~1\weblogic\wlserver -Dwls.home=C:\CONTAI~1\weblogic\wlserver\server -Dweblogic.home=C:\CONTAI~1\weblogic\wlserver\server -Dweblogic.management.discover=true -Dwlw.iterativeDev= -Dwlw.testConsole= -Dwlw.logErrorsToConsole= weblogic.Server


      many thanks for your help guys

      regards