1 Reply Latest reply: Nov 16, 2012 1:35 AM by Christian Erlinger RSS

    Form's Port Configuration Doubt

    carlos cortez
      Hi,

      I installed weblogic 10.3.4 on Windows Server 2008 R2 64 bits and Forms 11g 11.1.1.4 afer form's intallation i save the installation's resume, this is the resume i got:
      Oracle Portal, Forms, Reports and Discoverer Installation
                      Configuration Options
                                     Middleware Home Location: C:\u01\app\oracle\product\Middleware
                                     Oracle Home Location: C:\u01\app\oracle\product\Middleware\as_1
                                     Oracle Instance Location: C:\u01\app\oracle\product\Middleware\asinst_1
                                     Oracle Instance: asinst_1
                                     Domain Option: Create Domain
                                     Domain Name: FormsDomain
                                     Domain Home: C:\u01\app\oracle\product\Middleware\user_projects\domains\FormsDomain
                                     Domain Host Name: SRVWEBLOGIC
                                     Domain Port No: 7001
                                     User Name: weblogic
                                     Automatic Port Detection: true
                                     Administrator Console: http://SRVWEBLOGIC:7001/console
                                     EM Console: http://SRVWEBLOGIC:7001/em
                                     EMAgent URL: http://SRVWEBLOGIC:5155/emd/main
                                     Forms URL: http://SRVWEBLOGIC:8090/forms/frmservlet
                                     Reports URL: http://SRVWEBLOGIC:8090/reports/rwservlet
      In the weblogic's administration console i can see the managed server's ports as:
      WLS_FORMS    -> 9001
      WLS_REPORTS  -> 9002
      But in the installation's resume the port are 8090
      Forms URL: http://SRVWEBLOGIC:8090/forms/frmservlet
      Reports URL: http://SRVWEBLOGIC:8090/reports/rwservlet
      I tried the url's from the installation's resume:
      http://SRVWEBLOGIC:8090/forms/frmservlet
      http://SRVWEBLOGIC:8090/reports/rwservlet
      and they do not work, but if i change their ports to 9001 and 9002 as they appears in the weblogic's console they work

      So i have some doubts:

      -What is the porpuse of this ports ??
      -Why the Forms's url and Reports's url from the installation's resume are not working ??
      -can i change the WLS_REPORTS's port ??
      -there is a problem if for example i change the WLS_REPORTS's port to 8090 ??
      -i have created a new report server with opmnctl createcomponent and i can see that when i access to it, i have to use the same reports's port 9002, is there a way to change the new report_server's port ??

      Regards
      Carlos
        • 1. Re: Form's Port Configuration Doubt
          Christian Erlinger
          8090 would be the port of the Apache HTTP Server, 9001 and 9002 are the ports of the managed weblogic servers running the forms and the reports servlets. You can reach both weblogic servers under port 8090 as the HTTP Server talks via mod_weblogic to the weblogic servers. If you want to change the ports of the weblogic servers you can do so in the weblogic server console, but also you need to change them in the config files of Apache if you want them both to be reachable under the Apache port. Those files are located under

          ORACLE_INSTANCE/config/OHS/ohs1/moduleconf

          They should be pretty self explanatory.
          I tried the url's from the installation's resume:
          http://SRVWEBLOGIC:8090/forms/frmservlet
          http://SRVWEBLOGIC:8090/reports/rwservlet
          and they do not work, but if i change their ports to 9001 and 9002 as they appears in the weblogic's console they work
          See also in those config files. For the configuration of mod_weblogic you need to provide the hostname, so maybe you have a problem with your naming resolution (at least this was mostly the problem in my case). See that you get a fixed IP for your server if you don't have one already and check your DNS entries of your DNS server. If everything else fails you can still provide the IP adress instead the hostname.

          As for all your other questions the base problem should be the same; see that you get mod_weblogic running, and everything should be running via port 8090. If you want to change that listener port you can do so in the httpd.conf under

          ORACLE_INSTANCE/config/OHS/ohs1

          cheers