This discussion is archived
6 Replies Latest reply: Nov 26, 2012 6:43 AM by 964417 RSS

Not able to Install Oracle Forms & Reports, Fails at Domain creation stage

964417 Newbie
Currently Being Moderated
I want to install oracle forms in my laptop having windows 7 64 bit.

For that i downloaded Oracle Forms and Reports 11g Release 2 from oracle fusion middleware downloads.I installed jdk1.6.0_35 and then webserver logic which is a generic Installer.

The problem which I am facing is while installing Oracle Forms and Reports 11g Release 2, on reaching stage 14 of 14 i.e Configuration process the creation of domain is failing every time after a long time wait.
  • 1. Re: Not able to Install Oracle Forms & Reports, Fails at Domain creation stage
    910368 Oracle ACE
    Currently Being Moderated
    You maybe running into the probllem of having spaces or ( ) inyour path variable. You can test if this is the issue by

    In cmd go to the following path:
    D:\Oracle\Middleware\user_projects\domains\FRMDomain\bin

    and type the following command

    startweblogic.cmd

    If you get the result
    “_______________” was unexpected at this time.” It means you have a space or ( ) in your path variable.

    And you should fix it and then reinstall. I suggest you use my note for the installation. It make the process quite a bit easier.
    good Luck

    Tips and Tricks: The Dummies Guide to Installing Oracle Forms 11g R2 on 64 Bit
    http://oracleformsinfo.wordpress.com/2012/03/07/tips-and-tricks-the-dummies-guide-to-installing-oracle-forms-11g-r2-on-64-bit/
  • 2. Re: Not able to Install Oracle Forms & Reports, Fails at Domain creation stage
    964417 Newbie
    Currently Being Moderated
    Thanks
    i followed your steps but still the domain was not created and the installagtion hanged at the domain creation stage while configuration of oracle forms. when i checked running startweblogic.cmd in E:\Oracle\Middleware\user_projects\domains\FrmDomain folder using it is giving error unable to get file lock, will retry.....
    please help


    also tell me now what software i have to uninstall and from where i have to start the installation process again.....

    Thanks and Regards
    Deepak Kaushik
  • 3. Re: Not able to Install Oracle Forms & Reports, Fails at Domain creation stage
    910368 Oracle ACE
    Currently Being Moderated
    Unable to obtain file lock means that the process is already started.
    If you look in your task manager you will see the processes up and running so the new install can not get the file lock.

    The basic process is:
    ----------------------------------------
    First do deinstall from OI of Weblogic, forms and java
    Then delete
    C:\Program Files\Oracle
    D:\oracle\middleware

    Remove all Oracle entries from the PATH, JAVA_HOME, CLASSPATH variables

    Remove from registry:

    hkey_local_machine\software\oracle

    (If you created services then also remove)

    hkey_local_machine\system\controlset001\services\oracle frmdomain_adminserver
    hkey_local_machine\system\controlset001\services\oracle frmdomain_wls_forms
    hkey_local_machine\system\controlset001\services\oracleprocessmanager_frminst

    hkey_local_machine\system\controlset002\services\oracle frmdomain_adminserver
    hkey_local_machine\system\controlset002\services\oracle frmdomain_wls_forms
    hkey_local_machine\system\controlset002\services\oracleprocessmanager_frminst

    hkey_local_machine\system\currentcontrolset\services\oracle frmdomain_adminserver
    hkey_local_machine\system\currentcontrolset\services\ oracle frmdomain_wls_forms
    hkey_local_machine\system\currentcontrolset\services\ oracleprocessmanager_frminst

    Reboot the server

    Check that all services are all gone
    Check registry for oracle in all except data fields.
  • 4. Re: Not able to Install Oracle Forms & Reports, Fails at Domain creation stage
    964417 Newbie
    Currently Being Moderated
    Hi
    i followed each and every step but every time its either hanging or failing...... :(
    i searched the logs and found
    Error while starting the domain.
    Cause: Starting the Admin_Server timed out

    When i tried to run startweblogic.cmd i got---

    starting weblogic with Java version:
    Starting WLS with line:
    E:\Oracle\Java\bin\java -server   -Xms256m -Xmx512m  -XX:MaxPermSize=512m -Dweblogic.Name=AdminServer -Djava.security.policy=E:\Oracle\MIDDLE~1\WLSERV~1.3\server\lib\weblogic.policy  -Dweblogic.ProductionModeEnabled=true   -da -Dplatform.home=E:\Oracle\MIDDLE~1\WLSERV~1.3 -Dwls.home=E:\Oracle\MIDDLE~1\WLSERV~1.3\server -Dweblogic.home=E:\Oracle\MIDDLE~1\WLSERV~1.3\server   -Xms512m -Xmx1024m -XX:PermSize=256m -XX:MaxPermSize=512m -Doracle.home=E:\Oracle\Middleware\FRMHome -Ddomain.home=E:\Oracle\Middleware\user_projects\domains\FrmDomain -Dcommon.components.home=E:\Oracle\MIDDLE~1\ORACLE~1 -Djrf.version=11.1.1 -Dorg.apache.commons.logging.Log=org.apache.commons.logging.impl.Jdk14Logger -Ddomain.home=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1 -Djrockit.optfile=E:\Oracle\MIDDLE~1\ORACLE~1\modules\oracle.jrf_11.1.1\jrocket_optfile.txt -Doracle.server.config.dir=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1\config\FMWCON~1\servers\AdminServer -Doracle.domain.config.dir=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1\config\FMWCON~1  -Digf.arisidbeans.carmlloc=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1\config\FMWCON~1\carml  -Digf.arisidstack.home=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1\config\FMWCON~1\arisidprovider -Doracle.security.jps.config=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1\config\fmwconfig\jps-config.xml -Doracle.deployed.app.dir=E:\Oracle\MIDDLE~1\USER_P~1\domains\FRMDOM~1\servers\AdminServer\tmp\_WL_user -Doracle.deployed.app.ext=\- -Dweblogic.alternateTypesDirectory=E:\Oracle\MIDDLE~1\ORACLE~1\modules\oracle.ossoiap_11.1.1,E:\Oracle\MIDDLE~1\ORACLE~1\modules\oracle.oamprovider_11.1.1 -Djava.protocol.handler.pkgs=oracle.mds.net.protocol  -Dweblogic.jdbc.remoteEnabled=false  -Dwc.oracle.home=E:\Oracle\Middleware\FRMHome -Dclassic.oracle.home=E:\Oracle\Middleware\FRMHome  -Dweblogic.management.discover=true  -Dwlw.iterativeDev=false -Dwlw.testConsole=false -Dwlw.logErrorsToConsole=false -Dweblogic.ext.dirs=E:\Oracle\MIDDLE~1\patch_wls1036\profiles\default\sysext_manifest_classpath;E:\Oracle\MIDDLE~1\patch_ocp371\profiles\default\sysext_manifest_classpath  weblogic.Server
    *<21 Nov, 2012 10:33:08 PM IST> <Info> <Security> <BEA-090905> <Disabling CryptoJ JCE Provider self-integrity check for better startup performance. To enable this check, specify -Dweblogic.security.allowCryptoJDefaultJCEVerification=true>*
    *<21 Nov, 2012 10:33:08 PM IST> <Info> <Security> <BEA-090906> <Changing the default Random Number Generator in RSA CryptoJ from ECDRBG to FIPS186PRNG. To disable this change, specify -Dweblogic.security.allowCryptoJDefaultPRNG=true>*
    *<21 Nov, 2012 10:33:09 PM IST> <Info> <WebLogicServer> <BEA-000377> <Starting WebLogic Server with Java HotSpot(TM) 64-Bit Server VM Version 20.10-b01 from Sun Microsystems Inc.>*
    *<21 Nov, 2012 10:33:19 PM IST> <Info> <Management> <BEA-141281> <unable to get file lock, will retry ...>*


    please guide
  • 5. Re: Not able to Install Oracle Forms & Reports, Fails at Domain creation stage
    Kalyan Pasupuleti-Oracle Expert
    Currently Being Moderated
    Hi,

    It seems either process is already running some where or else you can clear tmp folder from Domain_Home/Servers/Adminserver/ and try to restart the server again.

    If lok file is not update in such cases you will find similar problem.

    Clear it once and try to restart it again it will solve your problem.

    Regards,
    Kal
  • 6. Re: Not able to Install Oracle Forms & Reports, Fails at Domain creation stage
    964417 Newbie
    Currently Being Moderated
    Hi Kal,
    everytime same lock problem is coming, i could not find where the service is running and how to stop that, i found the lok file in the path mentioned by u which was of *0kb* size. i tried to clearing tmp folder contents but could not as the files were being used in some process, which i could not find. I restarted the system but to my surprise all the content in start->Oracle Classic 11g - Home1 were gone.....what is to be done.....please help

    Thanks and Regards
    Deepak Kaushik

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points