4 Replies Latest reply: Nov 16, 2012 1:23 AM by 972461 RSS

    OL 5.8 RHEL kernel didn't load vmxnet3 module.

    972461
      I install Oracle Linux v 5.8 from kickstart , I also add vmware-tools package in the %pakcage section with the additional vmware repository.
      After kickstart installation completed, the vmware-tools package is install. But vmxnet3 module can load only when booting uek kernel, not RHEL kernel.

      I also want vmxnet3 also load when boot with RHEL kernel. Could you please help ? Thank you.

      ps. I've added vmxnet3 module to pxeboot initrd.img to make kickstart installation via nfs complete.
        • 1. Re: OL 5.8 RHEL kernel didn't load vmxnet3 module.
          Avi Miller-Oracle
          969458 wrote:
          After kickstart installation completed, the vmware-tools package is install. But vmxnet3 module can load only when booting uek kernel, not RHEL kernel.
          That's because the vmxnet3 module is built into the UEK and UEK2 kernels. Something about the package is failing, which is why it's not being built for the RHCK (which is the installer kernel). You will need to troubleshoot your kickstart, but I'm guessing something about the vmware-tools package installation isn't actually building the modules.
          • 2. Re: OL 5.8 RHEL kernel didn't load vmxnet3 module.
            972461
            Thanks Avi for reply

            Here 's my vmware-tools package. I don't test it yet whether it will build the module automatically.

            vmware-tools-xorg-drv-display-11.0.2.10-4.x86_64
            vmware-tools-core-8.6.5-2.x86_64
            vmware-tools-plugins-hgfsServer-8.6.5-2.x86_64
            vmware-tools-plugins-timeSync-8.6.5-2.x86_64
            vmware-tools-xorg-drv-mouse-12.6.10.0-4.x86_64
            vmware-tools-user-8.6.5-2.x86_64
            vmware-tools-plugins-unity-8.6.5-2.x86_64
            vmware-tools-esx-8.6.5-2.x86_64
            vmware-tools-foundation-8.6.5-4.x86_64
            vmware-tools-guestlib-8.6.5-3.x86_64
            vmware-tools-services-8.6.5-3.x86_64
            vmware-tools-plugins-deployPkg-8.6.5-2.x86_64
            vmware-tools-plugins-autoUpgrade-8.6.5-2.x86_64
            vmware-tools-plugins-powerOps-8.6.5-2.x86_64
            vmware-tools-plugins-vix-8.6.5-2.x86_64
            vmware-tools-help-8.6.5-2.x86_64
            vmware-tools-plugins-desktopEvents-8.6.5-2.x86_64
            vmware-tools-libraries-nox-8.6.5-2.x86_64
            vmware-tools-plugins-vmbackup-8.6.5-2.x86_64
            vmware-tools-plugins-guestInfo-8.6.5-2.x86_64
            vmware-tools-esx-nox-8.6.5-2.x86_64
            vmware-tools-libraries-x-8.6.5-2.x86_64
            vmware-tools-plugins-resolutionSet-8.6.5-2.x86_64
            • 3. Re: OL 5.8 RHEL kernel didn't load vmxnet3 module.
              Catch-22
              Apparently others ran into the same issue and posted a solution. You can find it in Google, e.g. searching for "Enabling VMXNET 3 for PXEBOOT and KICKSTART of RHEL". Did you check these posts?
              • 4. Re: OL 5.8 RHEL kernel didn't load vmxnet3 module.
                972461
                the package "kmod-vmware-tools-vmxnet3" fix my issue.
                Thank you all you guys.