6 Replies Latest reply: Dec 19, 2012 7:11 AM by 979797 RSS

    Validation Reports and Logic Accounts not working - FDM newbie

    660515
      Hi
      I am working on a R&D server getting to know FDM (11.1.2.1)

      I have set up an application which uploads a simple .txt file, maps the metadata & successfully loads the data to a simple BSO Essbase cube with the Essbase adaptor.

      When I try & set up logic accounts, it accepts the logic groups definitions, but nothing happens downstream of the data import - the logic account definitions have zero effect.


      Also I have tried to set up Validation Rules but although reports get generated at the 'check' stage, there is no meaningful information in them


      I have associated the location that I am loading from with the Logic Group and with the Validation Group.


      Maybe I am doing something fundamentally wrong to not get any logic acocunt values generated, and any meaningful content in the validation report.

      Any suggetsings ?

      Thanks
      M
        • 1. Re: Validation Reports and Logic Accounts not working - FDM newbie
          user10757003
          A litle more information is needed to allow any assistance.

          e..g.
          1. Are the logic accounts for internal FDM purposes or are they to create records which load to the target system.

          2. what sort of vaidations are you trying to achieve - Reporting tdata extracted form the target, form FDM, both?

          3. Have you created maping records for your Logic accounts?

          4. Is there data in the input file which will trigger the logic account processing?

          Could you provide a sample from your logic account definitions and your validaiton report definitions?
          • 2. Re: Validation Reports and Logic Accounts not working - FDM newbie
            660515
            Hi user10757003

            I managed to get Logic Accounts working now & populating the target database.

            In terms of Validations I was simply attempting to produce a validation report at the end of the load with a title & sub title, hence my Validation Group simply has the #Title & #SubTitle display values, with some generic ‘Rule Text’ values specified

            The Validation report that launches after the export step does not contain any of the Rule TExt values that I specified - it does not even contsain the name of the validation group, the location or the catagory

            Edited by: Ranzalman on Nov 16, 2012 12:12 PM
            • 3. Re: Validation Reports and Logic Accounts not working - FDM newbie
              user10757003
              1. Have you set the FDM Integration setting to allow Validation Reports?
              2. Have you added the entity(s) that are being processed to the validation group?

              Once the report runs, it will probably send an error message as (from memory) it needs to display some data.
              • 4. Re: Validation Reports and Logic Accounts not working - FDM newbie
                660515
                Yes - Validation has been set to 'Enabled' in integration settings, and i have imported all the Oracle reports from the XML file that is provided with the install.

                I have set up a Validation Entity which references a single entity BE.0011 and its parent in the Essbase target cube - I have tried many combinations of options in the Validation Entity, but I consistently get the error "Consolidate failed:Essbase API procedure: [EsbCalcFile] threw code : 103001...............invalid character in name (BE.0011) in ESSAPI function EsbCalcFile"

                When I don't specify the above Validation Entity in the Location specification, the data loads OK but the validation reports do not contain any meaningful content
                • 5. Re: Validation Reports and Logic Accounts not working - FDM newbie
                  user10757003
                  this is more an Essbase issue than FDM, however, isn't there something in Essbase where a member name used in a Calc script which includes a special character (period) as part of the name must be enclosed in brackets.
                  • 6. Re: Validation Reports and Logic Accounts not working - FDM newbie
                    979797
                    Hi Ranzalman,

                    Can you tell me what you’ve done to fix the logic account part of this post? I have exactly the same problem and, as you, I believe I’m doing something fundamentally wrong to not get the logic accounts values generated.

                    I have tried to put the simplest logic account and still does not have any impact…

                    Thanks in advance.

                    Emanuel