4 Replies Latest reply: Nov 19, 2012 2:48 PM by faisal niazi-2368916 RSS

    frm 18108 failed to load the following objects

    faisal niazi-2368916
      Hello All,

      I am developing custom forms for R 12.1.3, on my windows desktop i have made all the necessary setup like.

      1 Copy All the libraries from the resource directory to my forms directory.
      2. Add the path of forms folder to the forms_path in the registry.
      3. Copy the TEMPLATE and APPSTAND forms to my forms folder

      When I compile the form on my desktop there is no error but when I compile the same form in the forms folder of resource direcotory at server it gives me the error "frm 18108 failed to load the following objects", as a result all the form controls for which I have update the Subclass information are not visibe, while the items for which i do not update the subclass information, they are visible and working.

      Can you guys help me sort out this problem
        • 1. Re: frm 18108 failed to load the following objects
          Hussein Sawwan-Oracle
          Ogrey wrote:
          Hello All,

          I am developing custom forms for R 12.1.3, on my windows desktop i have made all the necessary setup like.

          1 Copy All the libraries from the resource directory to my forms directory.
          2. Add the path of forms folder to the forms_path in the registry.
          3. Copy the TEMPLATE and APPSTAND forms to my forms folder

          When I compile the form on my desktop there is no error but when I compile the same form in the forms folder of resource direcotory at server it gives me the error "frm 18108 failed to load the following objects", as a result all the form controls for which I have update the Subclass information are not visibe, while the items for which i do not update the subclass information, they are visible and working.

          Can you guys help me sort out this problem
          What is your server OS?

          Are you logged in as applmgr user? Have you sourced the application env file before running the command?

          What does "echo $FORMS_PATH" return?

          Please see these docs.

          FRM-18108 while compiling form on HP Unix [ID 260477.1]
          Using the OracleAS 10.1.2 Forms and Reports Builders with Oracle Applications Release 12 [ID 444248.1]
          How to Generate Form, Library and Menu for Oracle Applications (11i and R12) [ID 130686.1]
          Oracle Forms in Applications FAQ [ID 177610.1]
          11i: Error Opening TEMPLATE.fmb in Forms Builder [ID 236803.1]

          https://forums.oracle.com/forums/search.jspa?threadID=&q=FRM-18108&objID=c3&dateRange=all&userID=&numResults=15&rankBy=10001

          Thanks,
          Hussein
          • 2. Re: frm 18108 failed to load the following objects
            faisal niazi-2368916
            Hello

            Thanks for the reply, server OS is Oracle Linux 5.5 , and yes I am logged in as Applmgr and I dont understand this question of yours "Have you sourced the application env file before running the command?" how can i do that?

            I have checked the documents you listed, cant find any thing helping..

            Regards
            • 3. Re: frm 18108 failed to load the following objects
              Hussein Sawwan-Oracle
              Ogrey wrote:
              Hello

              Thanks for the reply, server OS is Oracle Linux 5.5 , and yes I am logged in as Applmgr and I dont understand this question of yours "Have you sourced the application env file before running the command?" how can i do that?

              I have checked the documents you listed, cant find any thing helping..

              Regards
              You need to source the application env file APPS<CONTEXT_NAME>.env which is located under $APPL_TOP directory.

              Table 2-2 Locations of Applications Environment Files
              http://docs.oracle.com/cd/E18727_01/doc.121/e12841/T120505T120509.htm#338715

              Thanks,
              Hussein
              • 4. Re: frm 18108 failed to load the following objects
                faisal niazi-2368916
                Thanks again, but this error was resolved when I compiled the form in the forms directory of resource, before that i was using the full path like /u01/CRP/..... but when i moved to the directory where the fmb was location, then this error has been solved,,, thanks for your help though.