This discussion is archived
2 Replies Latest reply: Nov 18, 2012 9:41 PM by rthampi RSS

Developer 6i, :PARAMETER.name as initial value for block columns

rthampi Explorer
Currently Being Moderated
Hi guys

We are trying to revamp an age old client-server application and during form load, under trigger WHEN-NEW-FORM-INSTANCE we are setting up values like
:PARAMETER.ORG_ID := 'SOMETHING';
:PARAMETER.USERNAME := 'SOMETHING';

and later at block level (table based) we are assigning the :PARAMETER.ORG_ID, :PARAMETER.USERNAME to block columns. To our utter surprise, developer 6i doesn't read the parameter values for initial values! With developer 10g, the same populates without any troubles.

Any suggestions?

regards,

raj
  • 1. Re: Developer 6i, :PARAMETER.name as initial value for block columns
    Andreas Weiden Guru
    Currently Being Moderated
    In my eyes you have two choices:

    1. Check if you are on the latest patchset for forms6i and if not, apply that.
    2. Try another way to initialize the Defaults, maybe using globals.
  • 2. Re: Developer 6i, :PARAMETER.name as initial value for block columns
    rthampi Explorer
    Currently Being Moderated
    Andreas Weiden wrote:
    In my eyes you have two choices:

    1. Check if you are on the latest patchset for forms6i and if not, apply that.
    2. Try another way to initialize the Defaults, maybe using globals.
    Thank you Andreas for your reply. Actually the "help" clearly mentions that the initial values are populated during a "Create record" event, and the forms just does that. Ie, when the forms loads, the single block is in data entry mode.
    You delete the first record, and a create record trigger is fired and the initial values are populated into the columns :)
    We are using Developer 6i with patch 18, which is the latest for client server architecture we believe or we are informed.

    Our curiosity it all about why two different versions of developer suite treats the same requirement different ways. 10g forms just populate the initial values while the form loads, when 6i forms doesn't.

    Anyway, after some goof ups, we are assigning the values to column during the FORM load, using WHEN-NEW-FORM-INSTANCE trigger and it does what we want :)

    Thanks once again

    regards,

    raj

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points