4 Replies Latest reply: Nov 20, 2012 1:34 PM by Mehabub Sheikh RSS

    11GXE on CentOS 5 64 Bit VPS OpenVZ Virtualization

    Mehabub Sheikh
      Hi,
      I am trying to install 11GXE on CenOS 5 64bit and I edited the kernel parameters
      like below
      fs.aio-max-nr = 1048576
      fs.file-max = 6815744
      kernel.shmall = 2097152
      kernel.shmmax = 4294967295
      kernel.shmmni = 4096
      kernel.sem = 250 32000 100 128
      net.ipv4.ip_local_port_range = 9000 65500
      But it is throwing
      error: permission denied on key 'fs-aio-max-nr' 
      error: permission denied on key 'fs.file-max'
      error: permission denied on key 'net.ipv4.ip_local_port_range'
      Could you please help me?

      Thanks,
      Mehabub

      Edited by: Mehabub Sheikh on Nov 18, 2012 7:38 AM
        • 1. Re: 11GXE on CentOS 5 64 Bit VPS OpenVZ Virtualization
          Udo
          Hi,
          error: permission denied on key 'fs-aio-max-nr'
          [...]
          Could you please help me?
          It seems you are either not using the root user to change these parameters or your VPS (your original post indicated you are using that virtualization plattform) doesn't allow you to change these parameters at all.
          Either way, it doesn't seem to be a problem specific to Oracle Database XE but an OS/VM-level topic. I'd recommend to post to some forum that covers this.

          -Udo

          Edited by: Udo on 19.11.2012 10:08
          • 2. Re: 11GXE on CentOS 5 64 Bit VPS OpenVZ Virtualization
            Mehabub Sheikh
            When I start
            /etc/init.d/oracle-xe configure
            I get error ORA-00845: MEMORY_TARGET not supported on this system+ in CloneRmanRestore.log
            I have put memory target 970M in init.ora and initXETemp.ora file.
            I again ran */etc/init.d/oracle-xe configure* but still get the same error.

            Thanks,
            Mehabub
            • 3. Re: 11GXE on CentOS 5 64 Bit VPS OpenVZ Virtualization
              Veeresh.S
              if you want to use MEMORY_TARGET(Automatic Memory Management) then /dev/shm filesystem size should be greater than or equal to MEMORY_TARGET/MEMORY_MAX_TARGET value. df -h will confirm that.

              so make sure /dev/shm has enough space before thinking of using MEMORY_TARGET.

              Or you have other option Instead of using MEMORY_TARGET try using Automatic Shared Memory Management ie by setting sga & pga manually in pfile and start the database.

              pga_aggregate_target = 100M
              sga_target = 500M
              • 4. Re: 11GXE on CentOS 5 64 Bit VPS OpenVZ Virtualization
                Mehabub Sheikh
                for me /dev/shm mount point was not there. So created one by following
                http://technodope.com/tech/tips-and-tricks/how-to-fix-ora-00845-memorytarget-not-supported-on-this-system-error/
                and then it worked fine.

                Thanks,
                Mehabub