7 Replies Latest reply on Nov 22, 2012 8:58 AM by Philip Stoyanov-Oracle

    Issues using SVN - authentication cancelled error and storing system types

      I'm constantly having issues using SVN and saving more than one model to the repository. The issue seems to revolve around where I select to "Choose versioned folder for storing system types".

      I have followed the demo provided on the ODDM site (http://download.oracle.com/otn_hosted_doc/sqldev/CollaborativeSupport/CollaborativeSupport.html) in setting up SVN and it works fine with the first model I check in but not any subsequent models. I am using Tortoise SVN 1.7.8 for my SVN repository. My ODDM versions is I haven't applied the latest patch but the bug fixes don't seem to relate to this.

      Basically the issue is this. When I create a folder in my repository and check it out, I can save a model in the local versioned folder, add it to repository and then when the prompt for "Choose versioned folder for storing system types" appears I select the same local versioned folder and all is works fine, as does the demo on the ODDM site. I can make changes and commit and everything seems ok.

      I then have another model I would like to add to my version control and so I open it, save it in my version controlled folder and the prompt appears which says "Choose versioned folder for storing system types" and so I choose the same folder and it saves my model in my local folder but does not add it to the SVN repository. If I look at the SVN messages I see an error - svn: authentication cancelled. If I try committing it I keep seeing this same message.

      The reason I believe it has something to do with the folder for storing system types is because of the following. My SVN structure is as follows:


      When I saved my first model in the versioned directory if I choose svnrep\trunk\warehouse\ for the versioned folder for system types it works fine. If I choose svnrep\trunk\warehouse\modelA or another folder on my local drive I get this same error - svn: authentication cancelled. That's what leads me to believe my issue has something to do with this. When I then try save my second model I have tried all different locations for this versioned folder for system types but have never successfully been able to add it to version control.

      There was one exception though which also leads me to believe my issues stem around this version controlled folder for system types. On one occassion after having tried many different things, there was a point when I tried adding my second model to the versions folder and it never asked me to choose a versioned folder for storing system types and so it worked fine and I was able to add it successfully to the repository. I was able to add quite a few other models to it all successfully because I never received a prompt to choose versioned folder for system types. Now a few days later that I'm trying to add more models to the repository though I am getting the message again to choose the versioned folder for storing system types and again I can not add any new models to the repository.

      Can anyone help with some of these issues?