0 Replies Latest reply: Nov 19, 2012 9:52 AM by 437473 RSS

    Create aggregates with Summary advisor or Aggregate Persistence utility

    437473
      Hi all,

      OBIEE 11.1.1.6.2 - Exalytics

      When using Summary Advisor or Aggregate Persistence utility in admin-tool, you get a script to create the aggregates.
      If one of the measures in the script is'nt available on the level specified shouldn't it then bee discarded in the aggregate?

      In my simple example below I get a column in the aggregate with all NULL-values for the measure "Measure_2".
      -----------
      Logical model:

      LOGICAL_FACT

           FACT_TABLE_A
                Dim_A_Detail_level
                Dim_B_Detail_level
                Measure_1

           FACT_TABLE_B
                Dim_A_Detail_level
                Measure_2

           AGGREGATE CREATED
      SA_ag_test
           Dim_A_level_1
           Measure_1 -- Correct values
                Measure_2 -- NULL-values FOR ALL ROWS !

      AGGREGATE SCRIPT
      CREATE aggregates
      "ag_test"
      for "A"."LOGICAL_FACT"("Measure_1", "Measure_2")
           at levels ("A"."Dim_A"."Detail_level", "A"."Dim_B"."Detail_level")
           using connection pool "TT"."TT_CP"
           in "TT".."Exalytics";

      -----------------

      Of course if I manually choose to not include then column "Measure_2" in the script there will be no problem, but when working in a larger logical model and you get the script from the utility thats not easily done.

      So is this a expected behavior or a bug ?

      Regards,
      Samuel