0 Replies Latest reply: Nov 21, 2012 2:22 AM by 952693 RSS

    webtier install: Error in invoking target 'client_sharedlib' of makefile

      Hi all,

      I am trying to install webtier, when the progress achieves to 93%, an error is displayed as follows:
      Error in invoking target 'client_sharedlib' of makefile '/scratch/user/Oracle/Middleware/Oracle_WT1/rdbms/lib/ins_rdbms.mk'. See '/scratch/user/app/oraInventory/logs/install2012-11-21_12-07-17AM.log' for details.

      I have tried both weblogic 10.3.6 generic and linx32. The installed machine is linux64.
      When I view the log, the hints are as follows:

      [2012-11-21T00:09:10.815-08:00] [OUI] [NOTIFICATION] [] [OUI] [tid: 22] [ecid: 0000JgY0rUV0bqP5If_Aif1Gf8ir00000D,0] /scratch/user/Oracle/Middleware/Oracle_WT1/bin/genclntsh[[

      [2012-11-21T00:09:11.354-08:00] [OUI] [NOTIFICATION] [] [OUI] [tid: 23] [ecid: 0000JgY0rau0bqP5If_Aif1Gf8ir00000E,0] /usr/bin/ld: cannot find -lstdc++_nonshared[[
      [2012-11-21T00:09:11.361-08:00] [OUI] [NOTIFICATION] [] [OUI] [tid: 23] [ecid: 0000JgY0rau0bqP5If_Aif1Gf8ir00000E,0] ld returned 1 exit status[[
      genclntsh: Failed to link libclntsh.so.11.1
      make: *** [client_sharedlib] Error 1

      [2012-11-21T00:09:11.367-08:00] [OUI] [NOTIFICATION] [] [OUI] [tid: 18] [ecid: 0000JgY0izO0bqP5If_Aif1Gf8ir000009,0] End output from spawned process.
      [2012-11-21T00:09:11.374-08:00] [OUI] [NOTIFICATION] [] [OUI] [tid: 18] [ecid: 0000JgY0izO0bqP5If_Aif1Gf8ir000009,0] ----------------------------------
      [2012-11-21T00:09:11.380-08:00] [OUI] [NOTIFICATION] [] [OUI] [tid: 18] [ecid: 0000JgY0izO0bqP5If_Aif1Gf8ir000009,0] Exception thrown from action: make[[
      Exception Name: MakefileException
      Exception String: Error in invoking target 'client_sharedlib' of makefile '/scratch/user/Oracle/Middleware/Oracle_WT1/rdbms/lib/ins_rdbms.mk'. See '/scratch/user/app/oraInventory/logs/install2012-11-21_12-07-17AM.log' for details.

      Someone install webtier on another machine following the same process successfully. So I think there is something wrong for the environment and I could not figure it out.

      I also tried to save gcc and g++ with .save,
      and vi gcc with gcc.save -m32 $*
      and link g++ to gcc

      Any suggestions would be helpful.
      Thanks for your great help.