9 Replies Latest reply: Dec 6, 2012 6:47 AM by user12273962 RSS

    Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?

    975559
      I have two Dell R710's in a lab that I am attempting to create a 2 node OVM cluster.
      I am specifically looking for assistance with the Cisco etherchannel setup and OVM bonding on the interfaces.

      I have configured bonding with Cisco and VMWare many times, I am looking for assistance with OVM.
      A document, an email or any information I would gladly accept.

      Thanks.
        • 1. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
          budachst
          Bonding with OVMM, especially LACP bonds are quite easy to setup in OVMM. First your have to configure your switch and i assume that you have done that already.
          Then select the server you want to create a bond on and choose "Bonds Ports" as the perspective on the right hand side. Click on the "+" button and create a bond.
          It's really easy.

          Cheers
          • 2. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
            975559
            Thank you for the reply. So I am guessing my switch configuration will look something like this :

            switchport
            switchport mode acces
            switchport access vlan 10 (for example)
            spanning tree portfast
            access-group 1 mode active

            interface port-channel 1
            switchport
            switchport mode access
            switchport access vlan 10

            To me this configuration is LACP not Cisco etherchannel. It sounds like LACP is what OVM prefers.
            Does this look correct ?
            • 3. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
              user12273962
              I run a few 4948s.... here is what I have...

              interface Port-channel1
              description LACP channel
              switchport trunk native vlan 10
              switchport trunk allowed vlan 10,11-etc
              switchport mode trunk
              spanning-tree portfast trunk

              interface GigabitEthernet1/0/36
              description eth2/eth3
              switchport trunk native vlan 10
              switchport trunk allowed vlan 10,11-etc
              switchport mode trunk
              channel-group 1 mode active

              LACP is an option for etherchannel...
              • 4. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
                975559
                Thank you for the reply. When I look at the configuration for your 4948's, it looks like you are tagging your traffic on a layer 3 trunk ?
                You also specify that LACP is an option. Would you reply with what the LACP port channel would look like ?
                This is very helpful. I never considered a layer 3 trunk and then tagging the native vlan.
                But I like the concept since I have three vlan's on each OVM host.
                • 5. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
                  user12273962
                  I actually was wrong. I am running 2960s. We considered 4948s but opt for the 2900 series. Should be similar if not identical as far as lacp is concerned.

                  lacp is a option for ether channels. As well as pagp. Portchannels are by default lacp.

                  Oracle VM can use LACP and is not compatible with pagp. At least not that I know of.

                  Below is an example of the traffic on a working lacp link.

                  Channel group: 1
                  Gi1/0/35 13087824 405144 0 0 0 0 0
                  Gi1/0/36 13088080 405143 0 0 0 0 0

                  Nice and even :)

                  My portchannel groups include only layer 2 ports. They can contain either layer 2 or 3 ports. I'm just using layer 2 ports.

                  Not using vlan tagging. The native vlan tagging command assumes untagged traffic received is for "native vlan".

                  Oracle VM does have the ability to do vlan tagging but I do not use it and its a little tricky to setup on the default bond0. Been a little while since I considered it. Hope this makes sense.
                  • 6. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
                    975559
                    Yep, makes perfect sense.
                    You should consider the 4948 versus the 2960G.
                    It is a smoking hot fast switch compared to the 2960G.
                    My environment would crush the 2960G in about 10 seconds....:-)
                    • 7. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
                      user12273962
                      I only use the 2960s for management, cluster heartbeats and live migration. I use the Cisco nexus 5000 series for all the heavy traffic. The nexus switches are sweet.
                      • 8. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
                        Dave Smulsky
                        Am I missing something? The conf examples posted above do not include the "channel-protocol lacp" line that actually makes the port-channel use LACP, right?? Atleast thats how we do it..

                        We used to use 4948's and crushed them and were forced to use NX5K's with 2K fabric extenders and full 10Gb over TWINAX cables.. We still manage to even crush the 5010's every now and then.
                        • 9. Re: Oracle OVM 3.1.1 with Cisco 4948 - link aggregation ?
                          user12273962
                          The default is lacp. Adding the command doesn't change anything. There are many features in Cisco's iOS that default to certain values. Adding the command might be a good form of refernence but I can assure lacp is active on the config I posted. The stats posted prove it.