4 Replies Latest reply on Nov 23, 2012 10:57 AM by 975714

    Cannot connect to daemon

      'm trying to create a prototype application on 64-bit Windows 7 Proffesional SP1 using TimesTen (64-bit) insted of home written IMDB. When I install TimesTen, TimesTen Data Manager service is hosted and also few subdaemons and server. Everything seems fine, but ttDaemonAdmin refuse to connect to main daemon. When I kill the process from Task Manager I can run it with ttDaemonAdmin, but after that any command isn't working. Every time I get a "Unable to connect to daemon. Check daemon status", but it indicates that there is a daemon proces ("Daemon pid 3576 port 53396 instance tt1122_64"). Same thing happens when I try to run ttStatus and ttModInstall command, so I can't change port number or any other option. What could be a problem? Is it possible that port is blocked or something? I'm logged as user with admin privileges, but timestend proces owner is SYSTEM. I tried every imaginable solution I could find in oracle documentation, but nothing seems to work. Also I tried to install it on few other computers im my domain network and on 32-bit XP works fine, but on 64-bit Windows 7 doesn't. Please help!

      Thanx in advance,

        • 1. Re: Cannot connect to daemon
          This is the output I get what ever I try to do with ttDaemonAdmin:

          TimesTen Release (64 bit NT) (tt1122_64:53396) 2012-10-30T06:32:14Z
          Instance admin: nikola.bajic
          Instance home directory: C:\TimesTen\TT1122~1\
          World accessible
          Daemon home directory: C:\TimesTen\TT1122~1\srv\info
          PL/SQL enabled.

          Failed to determine TimesTen Server process information.
          Error code: TT799. Unable to connect to daemon; check daemon status)

          TimesTen status report as of Thu Nov 22 15:14:16 2012

          Daemon pid 5092 port 53396 instance tt1122_64
          No TimesTen server running
          Accessible by any group
          End of report
          • 2. Re: Cannot connect to daemon
            I use TimesTen on Windows 7 Professional 64-bit every day and it works fine so there is something specific in your setup. Do you have a 3rd party firewall or security solution that intercepts communication installed? Is something else already using the port (53396)that the dameon is using?

            • 3. Re: Cannot connect to daemon
              It looks like the main daemon has started - using port 53396, but the main ttcserver process, which uses port 53397 by default, has not been spawned by the main daemon.

              It's probably best to try to do

              ttDaemonAdmin -stop
              ttDaemonAdmin -start

              then check the ttmesg.log file in


              to see what errors it reports when the main daemon tries to spawn the main ttcserver.

              We've seen before that 32bit TT on Windows has dependencies on some old .dlls which were missing. It might be something similar to this for 64bit. This was diagnosed before by running the ttcserver executable manually and see the Windows error dialogue. In 11.2.2. this is C:\TimesTen\tt1122_64\bin\ttcserver1122
              • 4. Re: Cannot connect to daemon
                I know that it shouldn't be Win7 problem, I installed it on home computer without any problems. Also, I installed X-NetStat and listed all ports used by applications but none of them is using same port as tt main daemon. So, the only thing that might be a problem here is firewall or security system, so I'll talk to administrators and hopefully they will make it work. ;) Thanks for quick reply

                ttcserver process is started, I can see it in Windows Task Manager, but comunnication with the daemon is problem. I cannot even execute ttDaemonAdmin -stop command, it throws "Unable to connect to daemon" massage. If the daemon is not started I can start it with ttDaemonAdmin -start, but after that I can't comunicate with it anymore.