2 Replies Latest reply: Nov 22, 2012 11:13 AM by 975753 RSS

    Cannot login to CC&B

    975753
      Hi everybody,
      I am new to CC&B, the installed passed without any problem, when installing the framework V2.2.0 i specified :
      ==>Application admin user = usertest1
      ==>application admin user password=usertest100
      My problem is that i cannot connect to cc&b using usertest1/usertest100 cc&b shows unable to login.
      when i add <user username="SYSUSER" password="sysuser003" roles="cisusers,admin,manager"/> to my C:\SPL\envtest1\product\tomcatBase\conf\tomcat-users.xml
      It works, i am able to login only using SYSUSER/sysuser003 but not using the user i created while i was installing the framework and cc&b.

      this is my environ.ini:

      THIS IS A SYSTEM MODIFIED FILE!!!
      # DO NOT EDIT MANUALLY
      MPLSTART=N
      NLS_LANG=AMERICAN_AMERICA.UTF8
      SPLENCPASS=215452445153445253100F0F21
      JVMchild_OPTIONS=-Xmx512m -server -Dfile.encoding=ISO8859_1 -cp C:\SPL\envtest1\splapp\standalone\config;C:\SPL\envtest1\splapp\standalone\lib\activation_api-1.1.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-beanutils-core-1.7.0.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-cli-1.1.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-codec-1.3.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-collections-2.1.1.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-fileupload-1.2.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-httpclient-2.0.2.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-io-1.3.2.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-lang-2.2.jar;C:\SPL\envtest1\splapp\standalone\lib\commons-logging-1.0.4.jar;C:\SPL\envtest1\splapp\standalone\lib\concurrent-1.3.4.jar;C:\SPL\envtest1\splapp\standalone\lib\dom4j-1.6.1.jar;C:\SPL\envtest1\splapp\standalone\lib\hibernate-3.2.5.ga.jar;C:\SPL\envtest1\splapp\standalone\lib\icu4j-3.6.1.jar;C:\SPL\envtest1\splapp\standalone\lib\jaxen-1.1.1.jar;C:\SPL\envtest1\splapp\standalone\lib\jcip-annotations.jar;C:\SPL\envtest1\splapp\standalone\lib\jta.jar;C:\SPL\envtest1\splapp\standalone\lib\jtds-1.2.jar;C:\SPL\envtest1\splapp\standalone\lib\log4j-1.2.15.jar;C:\SPL\envtest1\splapp\standalone\lib\mail_api-1.4.jar;C:\SPL\envtest1\splapp\standalone\lib\mfcobol.jar;C:\SPL\envtest1\splapp\standalone\lib\ojdbc5-11.1.0.7.0.jar;C:\SPL\envtest1\splapp\standalone\lib\orai18n-collation.jar;C:\SPL\envtest1\splapp\standalone\lib\orai18n-mapping.jar;C:\SPL\envtest1\splapp\standalone\lib\orai18n-utility.jar;C:\SPL\envtest1\splapp\standalone\lib\orai18n.jar;C:\SPL\envtest1\splapp\standalone\lib\serializer-2.7.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-base-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-ccb-2.3.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-servicebeaninterface-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-serviceclient-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-shared-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-spml-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-web-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\spl-xai-2.2.0.jar;C:\SPL\envtest1\splapp\standalone\lib\stax-api-1.0.1.jar;C:\SPL\envtest1\splapp\standalone\lib\stax2.jar;C:\SPL\envtest1\splapp\standalone\lib\staxmate-0.9.1.jar;C:\SPL\envtest1\splapp\standalone\lib\wstx-asl-3.2.1.jar;C:\SPL\envtest1\splapp\standalone\lib\xalan-2.7.0.jar;C:\SPL\envtest1\splapp\standalone\lib\xmlparserv2.jar;C:\SPL\envtest1\splapp\standalone\lib\xquery.jar;C:\SPL\envtest1\splapp\standalone\lib\xstream-1.2.1.jar;C:\SPL\envtest1\splapp\standalone\lib\yjp-controller-api-redist.jar
      WEB_SPLUSER=usertest1
      SPLEBASE=C:\SPL\envtest1
      XAIApp=XAIApp
      SPLDB=oracle
      SPLENVIRON=envtest1
      WEB_maxAge=28800
      WEB_WLPORT=6500
      WEBENCPASS=21524F4B40434C484D21
      WEB_SPLPASS=usertest100
      ENCODING=true
      DBPASS=ENC(gcG8M+UVKxwedHZ6ftn2YD0OPkT6l+z0r11c+jsQh7M=)
      DIRSEP=\
      SPLADMIN=Administrateur
      WEB_isDevelopment=true
      DIALECT=org.hibernate.dialect.Oracle10gDialect
      REL_CBL_THREAD_MEM=false
      CMPDB=oracle
      ORACLE_SID=ccbdemo
      appViewer=appViewer
      DESC=environnement test 1
      WEB_TCATSHUTPORT=6501
      WLSSPL=Y
      SPLWEBAPP=SPLWeb
      MPLADMINPORT=6502
      highValue=\uF8FF
      SPLWAS=TCAT
      WEB_isExpanded=true
      SPLApp=root
      SPLADMINGROUP=cisgrp
      SPLOUTPUT=C:\SPL\sploutput\envtest1
      RJVM=true
      BSN_WLHOST=ITNVAFRICA
      JavaEncoding=UTF8
      WEB_maxAgeI=28800
      XAISTARTWAITTIME=90
      DOC1SCRIPT=_ccbPrintDoc.cmd
      SPLSERVICEAPP=SPLService
      BSNENCPASS=21524F4B40434C484D21
      BSN_JVMCOUNT=2
      DB2MPLuse=
      DBENCPASS=214C445148444C21
      modules=base,ccb,cm
      WEB_WLHOST=ITNVAFRICA
      BATCHTHREADS=5
      SPLVERSION_NUM=2.2.0
      WEB_preloadall=false
      DBNAME=ccbdemo
      DOC1BILLSCRIPT=_ccbPrint.cmd
      WEB_WLAUTHMETHOD=FORM
      BATCHENABLED=true
      help=help
      DBUSER=cisadm
      SPLVERSION=V2.2.0
      BSN_RMIPORT=6503
      BATCHDAEMON=true
      DBDRIVER=oracle.jdbc.driver.OracleDriver
      DBPORT=1521
      JVMMEMORYARG=512
      DBCONNECTION=jdbc:oracle:thin:@ITNVAFRICA:1521:ccbdemo
      DBSERVER=ITNVAFRICA
      WEB_isAppViewer=true
      jvmcommand=C:/SPL/Java/bin/java.exe

      this is my C:\SPL\envtest1\product\tomcatBase\conf\tomcat-users.xml
      <?xml version='1.0' encoding='utf-8'?>
      <tomcat-users>
      <role rolename="manager"/>
      <role rolename="tomcat"/>
      <role rolename="admin"/>
      <role rolename="wamusers"/>
      <role rolename="mwmusers"/>
      <role rolename="role1"/>
      <role rolename="cisusers"/>
      <role rolename="bausers"/>
      <role rolename="nmsusers"/>
      <user username="both" password="tomcat" roles="tomcat,role1"/>
      <user username="tomcat" password="tomcat" roles="tomcat"/>
      <user username="SYSUSER" password="sysuser003" roles="cisusers,admin,manager"/>
      <user username="role1" password="tomcat" roles="role1"/>
      <user username="SYSUSER12" password="sysuser12" roles="cisusers,admin,manager"/>
      <user username="usertest1" password="usertest100" roles="cisusers,admin,manager"/>
      <user username="SPLSLK" password="SPLSLK12" roles="cisusers,admin,manager"/>
      </tomcat-users>

      My question is : can we login to CC&B using a username different than SYSUSER ? if yes please what i am missing and what i have to do ?

      Any help could be appreciated,

      Thank you
        • 1. Re: Cannot login to CC&B
          Angel Perez
          The answer is YES, it is possible to login to CC&B using a user other than SYSUSER. The tomcat-users.xml file contains the Web Server user configuration for tomcat, but you need to create the Application user as well. The reason why your are being able to login to CC&B using the SYSUSER user right after install it's because the user is already registered in the application itself, in other words, it's living in the CC&B Database.

          What you need to do, is login using SYSUSER and go to Admin Menu > U > User, search for the SYSUSER and duplitace it. You can specify your new username here and special security configuration (application services) but the user password must be set in the tomcat-users.xml file. Just make sure the Username matcher the username you put in the tomcat-users.xml file.

          I hope it helps.
          • 2. Re: Cannot login to CC&B
            975753
            Thank you very very much, it helped me.