This discussion is archived
2 Replies Latest reply: Nov 26, 2012 11:13 AM by Dovi Lilling RSS

Redirect loop on application 4550

Dovi Lilling Newbie
Currently Being Moderated
Hi all.

Oracle XE 11g
Apex 4.1 which was upgraded from 4.0 long ago.
Win 7

I've changed the "Require HTTPS attribute" to Yes on the Security Settings page in Oracle Application Express Administration Services (http://127.0.0.1:8080/apex/apex_admin), and after applying the change, going to the DEV or administration pages (http://127.0.0.1:8080/apex, http://127.0.0.1:8080/apex/apex_admin respectively), results in a redirection to http://localhost:8080/apex/f?p=4550:10:<sessionID>::::: or http://localhost:8080/apex/f?p=4550:1:<sessionID>::::: (again, respectively), and a redirect loop error.

When going to http://127.0.0.1:8080, the browser redirects to http://127.0.0.1:8080/apex/f?p=4950:1, and gets the old-known "Application not found" error (which is OK, I guess - the error, not the redirect address).

And the most strange thing - when going to the app I developed directly (http://127.0.0.1:8080/apex/f?p=<appID>:1:<sessionID>:::::), it works OK (no edit buttons, though, although I log in as admin).

As you might guessed by now, the App is very important to me, and I don't want to lose it.

Can anyone please help? this is very urgent!
Thank you!
  • 1. Re: Redirect loop on application 4550
    Mehabub Sheikh Journeyer
    Currently Being Moderated
    Reversing HTTPS Requirement To reverse the Require HTTPS instance-level requirement:
    1. Connect in SQL*Plus or SQL Developer with the Application Express engine
    schema as the current schema, for example:
    ■ On Windows:
    SYSTEM_DRIVE:\ sqlplus /nolog
    connect sys as sysdba
    ■ On UNIX and Linux:
    $ sqlplus /nolog
    connect sys as sysdba
    When prompted enter the appropriate password.
    2. Run the following statement:
    ALTER SESSION SET CURRENT_SCHEMA = APEX_040100;
    3. Run the following statements:
    BEGIN
    APEX_INSTANCE_ADMIN.SET_PARAMETER('REQUIRE_HTTPS', 'N');
    commit;
    end;
    /
    This will set the HTTPS back to No

    Thanks,
    Mehabub
  • 2. Re: Redirect loop on application 4550
    Dovi Lilling Newbie
    Currently Being Moderated
    Thank you, Mehabub.
    I've already re-installed the APEX, after exporting my app using PL\SQL via this VERY helpful post by Joe Upshaw: Re: How to Export APEX Pages (don't forget to populate the app ID in APEX_APP_BACKUP_TARGETS), and that helped to reverse this situation.
    Your suggestion worked also to reverse this setting (yes, checked it again).

    But the question is what is the problem in requiring HTTPS, and how do I solve it.

    Thank you!

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points