7 Replies Latest reply: May 14, 2013 9:39 AM by AG IAM RSS

    OOTB SPML deployment

    AG IAM
      Hi All,

      Did anyone deployed OOTB SPML webservice in Webshpere.I tried as per the SPML doc available , but it is not working.

      Build is sucessful. I can see OIM-xel-WS in Enterprise applications, but I am able to start it.
      When tried to send a addrequest , it says Properties file not found in the path...Can some one tell me where to set the properties files path???
        • 1. Re: OOTB SPML deployment
          Rajiv Dewan
          When tried to send a addrequest , it says Properties file not found in the path...Can some one tell me where to set the properties files path???
          Which version of OIM are you using ?
          How are you sending addRequest ?
          Are you executing Sample HTTP Client ? If yes and OIM is 10g, did you updated spmlws.properties ?
          • 2. Re: OOTB SPML deployment
            AG IAM
            Hi Rajiv,

            Issue was with the env...
            I am able to execute the addrequest now, response is getting generated..but user is not created in OIM.I got below error in log..

            [27/11/12 15:09:13:423 EST] 00000082 SystemOut O WARN,27 Nov 2012 15:09:13,423,[SPMLWS.UTILITY],SOAP Header that it can process :{http://xmlns.oracle.com/OIM/provisioning}OIMUser
            [27/11/12 15:09:13:423 EST] 00000082 SystemOut O WARN,27 Nov 2012 15:09:13,423,[SPMLWS.UTILITY],SOAP Header that it can process :{http://xmlns.oracle.com/OIM/provisioning}lang
            [27/11/12 15:09:13:486 EST] 00000082 LdapRegistryI E SECJ0361E: Authentication failed for oimuser because user is not found in the registry.
            [27/11/12 15:09:13:502 EST] 00000082 LdapRegistryI E SECJ0336E: Authentication failed for user oimuser because of the following exception com.ibm.websphere.security.PasswordCheckFailedException: No user oimuser found
            [27/11/12 15:09:13:517 EST] 00000082 LTPAServerObj E SECJ0369E: Authentication failed when using LTPA. The exception is No user oimuser found.
            [27/11/12 15:09:13:564 EST] 00000082 SystemOut O ERROR,27 Nov 2012 15:09:13,564,[XELLERATE.ACCOUNTMANAGEMENT],Class/Method: tcUtilityFactory/tcUtilityFactory(Hashtable env, String psUserId, String psPassword) encounter some problems: java.lang.ClassCastException: Unable to load class: com.thortech.xl.ejb.interfaces._tcUnauthenticatedOperationsHome_Stub
            com.thortech.xl.security.tcLoginException: java.lang.ClassCastException: Unable to load class:

            It seems , OIM user is incorrect.
            • 3. Re: OOTB SPML deployment
              Rajiv Dewan
              Which user are you using to create Utilityfactory instance. try with XELSYSADM ?
              • 4. Re: OOTB SPML deployment
                AG IAM
                ya, I tried with xelsysadm , in logs no error , but user is not created in OIM. In our env oimuser is configured w/o password, so I have kept the password blank in addrequest
                • 5. Re: OOTB SPML deployment
                  AG IAM
                  Hi All,

                  I am getting below error..

                  [30/11/12 16:25:39:823 EST] 00000098 SystemOut O ERROR,30 Nov 2012 16:25:39,823,[SPMLWS.INITIALIZATION],Error in Initializing I18N Messages Resource Bundle
                  [30/11/12 16:25:39:823 EST] 00000098 SystemOut O ERROR,30 Nov 2012 16:25:39,823,[SPMLWS.INITIALIZATION],Error in Initializing Internal Messages Resource Bundle
                  [30/11/12 16:25:39:823 EST] 00000098 SystemOut O ERROR,30 Nov 2012 16:25:39,823,[SPMLWS.ENGINE],Failed to Initialize the Engine
                  [30/11/12 16:25:39:823 EST] 00000098 SystemOut O ERROR,30 Nov 2012 16:25:39,823,[ EXCEPTION WHILE PROCESSING PAYLOAD ],SPMLWS.Utility
                  com.oracle.xl.spmlws.framework.engine.EngineException: com.oracle.xl.spmlws.framework.util.AppException: java.util.MissingResourceException: Can't find bundle for base name InternalMessages, locale en_AU
                       at com.oracle.xl.spmlws.framework.engine.Engine.initialize(Unknown Source)


                  Anyone encountered similar error ???
                  • 6. Re: OOTB SPML deployment
                    AG IAM
                    Hi,

                    I am getting below error:

                    ERROR,13 Dec 2012 15:35:20,998,[XELLERATE.ACCOUNTMANAGEMENT],Class/Method: tcUtilityFactory/getPropertyValue encounter some problems: Unable to load class: com.thortech.xl.ejb.interfaces._tcUnauthenticatedOperationsHome_Stub
                    java.lang.ClassCastException: Unable to load class: com.thortech.xl.ejb.interfaces._tcUnauthenticatedOperationsHome_Stub

                    [13/12/12 15:35:20:998 EST] 0000004c SystemOut O DEBUG,13 Dec 2012 15:35:20,998,[SPMLWS.OIMEVENT],Thor.API.Exceptions.tcAPIException: Unable to load class: com.thortech.xl.ejb.interfaces._tcUnauthenticatedOperationsHome_Stub
                    [13/12/12 15:35:20:998 EST] 0000004c SystemOut O INFO,13 Dec 2012 15:35:20,998,[SPMLWS.OIMEVENT],Unable to load class: com.thortech.xl.ejb.interfaces._tcUnauthenticatedOperationsHome_Stub
                    Thor.API.Exceptions.tcAPIException: Unable to load class: com.thortech.xl.ejb.interfaces._tcUnauthenticatedOperationsHome_Stub
                    at Thor.API.tcUtilityFactory.getPropertyValue(Unknown Source)


                    Any idea what is missing here??
                    • 7. Re: OOTB SPML deployment
                      AG IAM
                      Hi All,

                      In SPML Requests can we by pass user password?
                      In our environment we are not using password for login to OIM , we are using security device. Can we have signature based login where we do not have to pass password in header?