This discussion is archived
6 Replies Latest reply: Nov 28, 2012 10:35 AM by JFuter RSS

Error Error Processing Request. ORA-01403: no data found

JFuter Newbie
Currently Being Moderated
To Whom It May Concern,

I am trying to install the APEX listener by either using WebLogic or the standalone mode, both to no avail. I went through all the installation steps with my DBA for the DB side of things and we got no error messages. When trying to configure the APEX listener either way, it's simply giving me the error in my post title once I setup my DB connection to the APEX_PUBLIC_USER schema. Has anyone ever seen this before? What is supposed to be in the APEX_PUBLIC_USER schema? When I look at mine it's empty, I see no objects, which seems a little off to me. Any help will be greatly appreciated because the documentation is pretty sparse and the error messages I'm seeing are far from insightful. One final thing to note is that the images seem to be working via the standalone mode, whereas with WebLogic it's not finding them because they're not displaying, but that's an issue I'll work on next as I'd like to first get APEX working with or without the images.

Thanks,

Josh
  • 1. Re: Error Error Processing Request. ORA-01403: no data found
    Prabodh Guru
    Currently Being Moderated
    Hi,
    I am trying to install the APEX listener by either using WebLogic or the standalone mode, both to no avail.
    Which version of ApexListener? The installation steps for 1.1.x are different from those for 2.0 EA.
    >
    I went through all the installation steps with my DBA for the DB side of things and we got no error messages. When trying to configure the APEX listener either way, it's simply giving me the error in my post title once I setup my DB connection to the APEX_PUBLIC_USER schema. Has anyone ever seen this before? What is supposed to be in the APEX_PUBLIC_USER schema? When I look at mine it's empty, I see no objects, which seems a little off to me.
    >
    What you see is normal. The APEX_PUBLIC_USER schema is empty.
    Have you unlocked the APEX_PUBLIC_USER account?
    >
    Any help will be greatly appreciated because the documentation is pretty sparse and the error messages I'm seeing are far from insightful. One final thing to note is that the images seem to be working via the standalone mode, whereas with WebLogic it's not finding them because they're not displaying, but that's an issue I'll work on next as I'd like to first get APEX working with or without the images.>
    Getting to see the Apex pages, even to configure 1.1.x , will not be possible without the images folder.

    Have you seen the ApexListener log file? For WLS it is the WLS logfile itself.

    Cheers,
  • 2. Re: Error Error Processing Request. ORA-01403: no data found
    JFuter Newbie
    Currently Being Moderated
    Prabodh,

    The version of APEX is 4.2 and the listener is 1.1.4.

    Yes, I am able to sign-in to it using SQL*Developer.

    I have not seen the ApexListener log file. Do you know which specific WLS logfile it is? One of the AdminServer logs?

    Thanks,

    Josh
  • 3. Re: Error Error Processing Request. ORA-01403: no data found
    JFuter Newbie
    Currently Being Moderated
    Ok, have the images working using WebLogic now. Had to re-create the i.war file while in the base directory of the unzipped apex.zip file so the path was correct to the images.

    Also, if I go into WebLogic and look at my deployed APEX.war, when I click on any of the 'Testing' tab's links, they all give me the same error as listed in this post's title.

    Josh
  • 4. Re: Error Error Processing Request. ORA-01403: no data found
    Prabodh Guru
    Currently Being Moderated
    A. Which is the HTTP Listener port on WLS where ApexListener is deployed? You have to use that port in the URL
    B. Have you followed the steps outlines in the Installation Guide in About the Listener Configuration File -> Locating the Configuration File?

    Cheers,

    PS:
    By default, the local server log file is located in the logs directory below the server instance root directory; for example, DOMAIN_NAME\servers\SERVER_NAME\logs\SERVER_NAME.log, where DOMAIN_NAME is the name of the directory in which you located the domain and SERVER_NAME the name of the server instance.

    Edited by: Prabodh on Nov 28, 2012 12:17 PM
  • 5. Re: Error Error Processing Request. ORA-01403: no data found
    JFuter Newbie
    Currently Being Moderated
    A. 7001, I am using that port
    B. Yes, I've followed all the manuals. The config I am seeing is in /tmp/apex/apex-config.xml

    Another question, my 'APEX_040200' and 'FLOW_FILES' schemas are currently locked, should they be that way? Could this be causing the issue?

    Thanks,

    Josh
  • 6. Re: Error Error Processing Request. ORA-01403: no data found
    JFuter Newbie
    Currently Being Moderated
    Wow, I feel quite silly now. Turns out the DBA ran the run time only install script. We removed the DB install and ran the full development environment script and all is up and working.

    Josh

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points