2 Replies Latest reply on Nov 28, 2012 2:18 PM by thatJeffSmith-Oracle

    SQL Developer Export hangs - version

      I installed SQL Developer Version Build MAIN-09.87 and try to export a query into csv file,
      it hangs after writing 100 rows, I don't see the file grows on OS, the progress-bar keeps saying 100 row
      I also tried .xls format, the problem remains.
      the downloaded file is sqldeveloper- (with JDK included)
      Your help is appreciated.
        • 1. Re: SQL Developer Export hangs - when data contains control chars
          I ran export for a different SQL, the .csv file was generated.
          Not sure if the issue I encounter is data-related. I want to point out that some of the return data contains ASCII control characters:

          This is the exact SQL for the hanged-export:

          select c.email_addr,c.job_title, regexp_replace(c.job_title,'[[:cntrl:]]','#'),
          t.job_title, regexp_replace(t.job_title,'[[:cntrl:]]','#')
          from HZ_IMP_CONTACTS_T t, my_contact c
          where t.batch_id=100002764150299
          and t.REL_ORIG_SYSTEM_REFERENCE = c.pr_dept_ou_id || ':' || c.row_id
          and rownum < 200

          Hope you can reproduce this issue.

          • 2. Re: SQL Developer Export hangs - when data contains control chars
            To reproduce, or to attempt to reproduce, we would need the data involved, not just your query.

            Can you attempt to limit the rows in your query to see if you can isolate the 'bad data' that you suspect might be causing our export to break?

            Also, try this as a workaround

            SELECT /*csv*/ c.email_addr, c.job_title, ...

            and execute with F5

            If this works, you'll have your csv data come back in the Script Output window and you can copy and paste it out to your file.