5 Replies Latest reply on Nov 29, 2012 9:58 AM by 976736

    Webutil Problem in Oracle Forms 10g

      Hi All,

      been reading various posts over time on the forums but this is the first time for me to post here.

      My name is george an i am a novice forms developer.(very novice i would say )

      i am in the process of altering an existing form, and i am trying to add webutil functionality to the form.

      i am succesfull getting webutil to run but i get some weired behaviour from the form, and in more detail i get the 40200 error.

      the error only appears after the usage of webutil in the form and this prevents the user from entering a query string in a text item (actually it is when the user tries to type in the text box that oracle throws the 40200).

      i am able to get around this problem, by moving the WEBUTIL DATA BLOCK at the end of the DATA BLOCKS tree. The form once more works as it should (queries etc) only that the webutil window and canvas are displayed on the top of my form (i.e webutil about form) and the user has to click OK to get rid of it.

      i have tried to hide the webutil window, the webutil canvas but i am unsuccesful.

      any ideas of how to keep the webutil data block at the end of the data block tree but not appearing in front of the form ??

      i hope i did not confuse you with my explanation.
      thank you,

        • 1. Re: Webutil Problem in Oracle Forms 10g
          I always leave my WEBUTIL database block as the last block like you are doing. Is the WEBUTIL block coming into focus when the user executes the form?

          If it is then Open the Property Palette for your form module - the very first node in the Object Navigator tree. There should be a "First Navigation Data Block" field - set that to the database block that you want to navigate to when the user executes the form module or in the Form-level Triggers create a WHEN-NEW-FORM-INSTANCE trigger (you probably already have one set up) and at the bottom of it put in logic like GO_ITEM('BLOCK_NAME.ITEM_NAME'); to reference the item that you want to start the user out it. Either of these two methods should keep the WEBUTIL database block from coming into focus.
          1 person found this helpful
          • 2. Re: Webutil Problem in Oracle Forms 10g
            Oracle Forms is Heirarchical. It uses the order in which items appear in the Object Navigator as the "Default" navigation order. Items like WebUtil should always appear after other objects (such as Data Blocks, Canvases and Windows). Making sure objects are listed in the right order in the Object Navigator is typically all you need to do, however, you could use the Form Module First Navigation Data Block property to override the default heirarchy (as MLBrown suggests) as well as write code in a When-New-Form-Instance trigger to Hide the WebUtil canvases and direct the form to the desired starting point (first navigation block/item).

            I personally, prefer to use the order of objects in the Object Navigator since this does not require any lines of code or the setting of properties.

            On a side note, it is always good to post your Forms version (eg: versus 10g) when posting a Forms question. :)

            • 3. Re: Webutil Problem in Oracle Forms 10g
              Hi craigb,

              Thanks for your input, i will make sure to check what you say out tomorrow when i go to the office.

              i managed to get a 'stupid' workaround, and that was to copy the code from the 'OK' button on the webutil canvas, and have it run on the form trigger 'when-new-window' or something like that, dont remember of hand. that did the trick but i will make sure to try what you say and change the code to reflect the changes you suggest.

              Thanks for the information,


              Edited by: 973733 on 28-Nov-2012 12:59
              • 4. Re: Webutil Problem in Oracle Forms 10g
                Hi ML Brown,

                i have tried a go_item in the when-new form instance but did not work for my scenario. maybe of the 'complexity' of the form i was trying to alter, and as i said, im not ver familiar with forms. nevertheless thanks for the info. i will make sure i will try it out again tomorrow.


                • 5. Re: Webutil Problem in Oracle Forms 10g

                  just tried altering (it was set to <Null>) the First Navigation Block in the form's properties to a soecific block and it works fine !!!

                  Thank you both for your help !