1 Reply Latest reply on Nov 28, 2012 7:53 PM by mseberg

    Log of execution of -->delete noprompt archivelog all

      Hi Folks

      I tried recover a datafile from backup and got this error:
      RMAN-06054: media recovery requesting unknown archived log for thread 1 with sequence 27 and starting SCN of 22469291

      After, we tried restore the archive log from backup, but
      RMAN-06004: ORACLE error from recovery catalog database: RMAN-20242: specification does not match any archived log in the repository

      We found in this query the archive:
      select name, thread#, sequence#, status, first_time, next_time, first_change#, next_change#
      from v$archived_log
      where 22469291 between first_change# and next_change#
      1 27 D 26-NOV-12 26-NOV-12 22433486 22469392
      The "name" is empty, but not in rman backup, like see above.
      I saw that someone runned, past days an invalid backup of database ( the path of DISK location invalid ). But the first command was this command
      delete noprompt archivelog all completed before 'sysdate-1';

      I guess that this deleted the archivelog that we need, and dont have either in rman or filesystem.

      Is there a query to get what archivelogs was deleted by the command above ?
        • 1. Re: Log of execution of -->delete noprompt archivelog all

          Not that I know of, but the view RC_BACKUP_ARCHIVELOG_DETAILS should give you a very good idea of what if you have a catalog.

          Otherwise check V$BACKUP_ARCHIVELOG_DETAILS

          RC_LOG_HISTORY will give you the sequence numbers for the missing logs. The FIRST_TIME column can be compared to the date range. ( if no catalog then V$LOG_HISTORY )

          Best Regards


          Edited by: mseberg on Nov 28, 2012 1:09 PM