4 Replies Latest reply: Nov 29, 2012 8:26 AM by Srini Chavali-Oracle RSS

    Oracle Client installs with validated rpms

    lewonkas
      Hello,

      I'm new to the Oracle on Linux world (OL6), so hoping someone could point me in the right direction.
      I'm needing to set up some Oracle clients (11.2) on middle tier/application servers
      Looking around for a simple/repeatable way of meeting the pre-install requirements and was considering using the "validated" rpms.

      The oracle-rdbms-server-11gR2-preinstall rpm i believe is really for a database server setup, so it's doing some group/kernel parameter/package setup that i suspect isn't really required for a client only setup.

      Do people use those validated rpms for client only installs?
      Might there be a "Oracle Validated Client preinstall" rpm out there?
      Should I just script the package installs and user/group creation?

      Looking for some real world suggestions on how to make the client requirements/install process quick and easy!

      Thanks
      Steve
        • 1. Re: Oracle Client installs with validated rpms
          Avi Miller-Oracle
          lewonkas wrote:
          I'm needing to set up some Oracle clients (11.2) on middle tier/application servers
          Do you need the full client? We provide the Oracle Instant Client RPMs on ULN, which can be automatically installed.
          Do people use those validated rpms for client only installs?
          No idea.
          Might there be a "Oracle Validated Client preinstall" rpm out there?
          Nope.
          Looking for some real world suggestions on how to make the client requirements/install process quick and easy!
          If you're registered with ULN:

          1. Subscribe your server(s) to the ol6_<arch>_oracle channel
          2. # yum install oracle-instantclient11.2-basic

          The full list of Instant Client RPMs:

          oracle-instantclient11.2-basic
          oracle-instantclient11.2-basiclite
          oracle-instantclient11.2-devel
          oracle-instantclient11.2-jdbc
          oracle-instantclient11.2-odbc
          oracle-instantclient11.2-precomp
          oracle-instantclient11.2-sqlplus
          oracle-instantclient11.2-tools
          • 2. Re: Oracle Client installs with validated rpms
            rukbat
            Moderator Action:
            Thread now moved from the Oracle Linux forum,
            to the Database Installation forum, for closer topic alignment.

            That original forum is NOT a Oracle-Application-On-Linux forum.
            Your issue, as described by you, is a "how do I install my application while I happen to have Linux as my OS".
            • 3. Re: Oracle Client installs with validated rpms
              Helios-GunesEROL
              Hi;

              I suggest review:
              Master Note For Oracle Database Client Installation [ID 1157463.1]
              Client / Server / Interoperability Support Between Different Oracle Versions [ID 207303.1]

              Regard
              Helios
              • 4. Re: Oracle Client installs with validated rpms
                Srini Chavali-Oracle
                Pl also be aware that currently only 11.2.0.3 is certified with Linux 6.x versions - so you will need to install 11.2.0.3 client software

                http://docs.oracle.com/cd/E11882_01/relnotes.112/e23558/toc.htm#CHDFHIEA

                HTH
                Srini