3 Replies Latest reply: Dec 3, 2012 3:17 AM by Nicolas.Gasparotto RSS

    TMADMIN_CAT:188: ERROR: Error while obtaining the Bulletin Board parameters

    974967
      Hi ,everybody
      When I created and configured a App server domanin with PSADMIN, these errors below occurred,but log files didn't have useful info:
      -------------------------------
      PeopleSoft Domain Boot Menu
      -------------------------------
      Domain Name: HCMDOM

      1) Boot (Serial Boot)
      2) Parallel Boot
      q) Quit

      Command to execute (1-2, q) [q]: 1

      Archived a copy of the domain configuration to /appfs/people/opt/PS/PS_CFG_HOME/appserv/HCMDOM/Archive/psappsrv.cfg
      Attempting to boot bulletin board...
      tmadmin - Copyright (c) 2007-2008 Oracle.
      Portions * Copyright 1986-1997 RSA Data Security, Inc.
      All Rights Reserved.
      Distributed under license by Oracle.
      Tuxedo is a registered trademark.
      TMADMIN_CAT:188: ERROR: Error while obtaining the Bulletin Board parameters


      ==============ERROR!================
      Boot attempt encountered errors!. Check the TUXEDO log for details.
      ==============ERROR!================

      Do you wish to see the error messages in the domain log file? (y/n) [n] :y

      PSADMIN.23310 (0) [11/30/12 10:58:42](0) Begin boot attempt on domain HCMDOM
      PSADMIN.23310 (0) [11/30/12 10:58:42](0) End boot attempt on domain HCMDOM


      Do you wish to see the error messages in the Tuxedo log file? (y/n) [n] : y

      105842.peoplesoft.ynby.cn!PSADMIN.23310: Begin attempt on domain HCMDOM
      105842.peoplesoft.ynby.cn!PSADMIN.23310: End boot attempt on domain HCMDOM

      Press Enter to continue...

      Don't know how to solve it ...
        • 1. Re: TMADMIN_CAT:188: ERROR: Error while obtaining the Bulletin Board parameters
          Nicolas.Gasparotto
          OS ? Peopletools version ? Your path directory seems a bit strange, are you sure your env variables are set correctly ? Check stderr and stdout file of the domain as well as APPSERV log.

          Nicolas.
          • 2. Re: TMADMIN_CAT:188: ERROR: Error while obtaining the Bulletin Board parameters
            974967
            Hi,Nicolas
            Before I booted up the app server ,I set the environment variable PS_CFG_HOME to /appfs/people/opt/PS/PS_CFG_HOME,and the above error occured,but when I unset the PS_CFG_HOME,it booted up successfully.But another error occured when booted up :

            exec PSMONITORSRV -o ./LOGS/stdout -e ./LOGS/stderr -A -- -ID 232457 -D TESTSERV -S PSMONITORSRV : Failed.

            tmboot: CMDTUX_CAT:827: ERROR: Fatal error encountered; initiating user error handler
            exec tmshutdown -qy

            I checked the pemission to boot up app server :
            SQL> SELECT CLASSID, STARTAPPSERVER FROM PSCLASSDEFN WHERE CLASSID IN (SELECT OPRCLASS FROM PSOPRCLS WHERE OPRID='PS');
            CLASSID STARTAPPSERVER
            ------------------------------ --------------
            PSAPPS 1
            EOEN9000 1
            EOCO9000 1
            PTPT1100 1
            PTPT1200 1
            PTPT1300 1

            and update:
            SQL> UPDATE PSCLASSDEFN SET STARTAPPSERVER=1 WHERE CLASSID='PSAPPS';
            1 row updated.
            SQL> UPDATE PSCLASSDEFN SET STARTAPPSERVER=1 WHERE
            CLASSID='EOEN9000';
            1 row updated.
            SQL> UPDATE PSCLASSDEFN SET STARTAPPSERVER=1 WHERE
            CLASSID='EOCO9000';
            1 row updated.
            SQL> UPDATE PSCLASSDEFN SET STARTAPPSERVER=1 WHERE CLASSID='PTPT1100';
            1 row updated.
            SQL> UPDATE PSCLASSDEFN SET STARTAPPSERVER=1 WHERE CLASSID='PTPT1200';
            1 row updated.
            SQL> UPDATE PSCLASSDEFN SET STARTAPPSERVER=1 WHERE CLASSID='PTPT1300';
            1 row updated.

            After doing these,it booted up with the error:
            exec PSRENSRV -o ./LOGS/stdout -e ./LOGS/stderr -A -- -D TESTSERV -S PSRENSRV :
            Failed.

            tmboot: CMDTUX_CAT:827: ERROR: Fatal error encountered; initiating user error handler

            Then I configured the REN server :
            Values for config section - PSRENSRV
            log_severity_level=Warning
            io_buffer_size=8192
            default_http_port=7180
            default_https_port=7143
            default_auth_token=<my hostname>

            Boot up app server again :

            Booting server processes ...
            exec PSWATCHSRV -o ./LOGS/stdout -e ./LOGS/stderr -A -- -ID 42933 -D TESTSERV -S PSWATCHSRV :
            process id=24245 ... Started.
            exec PSAPPSRV -o ./LOGS/stdout -e ./LOGS/stderr -s@psappsrv.lst -- -D TESTSERV -S PSAPPSRV :
            process id=24246 ... Started.
            exec PSAPPSRV -o ./LOGS/stdout -e ./LOGS/stderr -s@psappsrv.lst -- -D TESTSERV -S PSAPPSRV :
            process id=24256 ... Started.
            exec PSSAMSRV -o ./LOGS/stdout -e ./LOGS/stderr -A -- -D TESTSERV -S PSSAMSRV :
            process id=24266 ... Started.
            exec PSRENSRV -o ./LOGS/stdout -e ./LOGS/stderr -A -- -D TESTSERV -S PSRENSRV :
            process id=24273 ... Started.
            exec PSMONITORSRV -o ./LOGS/stdout -e ./LOGS/stderr -A -- -ID 42933 -D TESTSERV -S PSMONITORSRV :
            process id=24279 ... Started.
            exec WSL -o ./LOGS/stdout -e ./LOGS/stderr -A -- -n //<my hostname>:7000 -z 0 -Z 0 -I 5 -T 60 -m 1 -M 3 -x 40 -c 5000 -p 7001 -P 7003 :
            process id=6834 ... Started.
            7 processes started.

            Here is my configurations:
            OS:RHEL 5.4
            DATABASE:ORACLE Database 11.2.0.1
            Peoplesoft Tools: 8.52
            Application version:HCM 9.1
            Domain configuration:
            ----------------------------------------------
            Quick-configure menu -- domain: HCMAPP
            ----------------------------------------------
            Features Settings
            ========== ==========
            1) Pub/Sub Servers : No 16) DBNAME :[PEOPDB]
            2) Quick Server : No 17) DBTYPE :[ORACLE]
            3) Query Servers : No 18) UserId :[PS]
            4) Jolt : No 19) UserPswd :[PS]
            5) Jolt Relay : No 20) DomainID :[TESTSERV]
            6) WSL : Yes 21) AddToPATH :[.]
            7) PC Debugger : No 22) ConnectID :[people]
            8) Event Notification: Yes 23) ConnectPswd:[peop1e]
            9) MCF Servers : No 24) ServerName :[<my hostname>]
            10) Perf Collator : No 25) WSL Port :[7000]
            11) Analytic Servers : No 26) JSL Port :[9000]
            12) Domains Gateway : No 27) JRAD Port :[9100]

            It seems OK,But when I tested the 3-tier connection :
            It prompted: Could not connect to appliaction server HCMAPP.possible causes are:the server name/IP address and port for the application server alias are incorrect....
            Contect your system administrator to check the Tuxedo log for more information
            But I can sign on the database using Application Designer,and app server already booted up.

            Additional ,the Tuxedo and Weblogic were installed within different directorys,does it matter?
            Do you need more configuration info?
            Thanks for you to reply my questions ~
            • 3. Re: TMADMIN_CAT:188: ERROR: Error while obtaining the Bulletin Board parameters
              Nicolas.Gasparotto
              I'd be rather skeptical about the way you found to make it work...

              Anyway, for the 3tier connection, you should have configured the WSL port in the domain's configuration file, create a profile within the Configuration Manager, and use it when you connect.

              Nicolas.