This discussion is archived
0 Replies Latest reply: Nov 30, 2012 7:07 AM by 682148 RSS

Ooops, dropped a streamed table(s)

682148 Newbie
Currently Being Moderated
Recently I dropped two tables that I had streamed without streams being down. The original tables were owned by schema OHSU. I have removed the tables from streams and re-added them and all seemed to be working fine. Unfortunately when I look at the DBA_APPLY_INSTANTIATED_OBJECTS view I see entries for the two tables I had dropped but the soure_object_owner is incorrect. I would like to clear these entries from the DBA view but nothing I have done has worked. One thing I tried was to set the SCN on this object to NULL

DBMS_APPLY_ADM.SET_TABLE_INSTANTIATION_SCN(
source_object_name => 'TABLE_NAME_TO_REMOVE',
source_database_name => 'SOURCE_DATABASE_NAME',
instantiation_scn => NULL);

I ran teh DBMS command for both the tables and they still exist in the view even though the tables are no longer being streamed nor do they exist on either the SOURCE and TARGET database espeically in the schema the view is reporting? Bar dropping all my streams queues and recreating them, is there a way to remove the two entries of these tables?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points