1 Reply Latest reply on Dec 3, 2012 6:04 AM by Ryansun-Oracle

    Help! Unable to set default date value for Tabular form DB date field!

      Version : 4.1.1

      Hi There,

      I thought this would be an easy one. But just not able to get it to work.

      I have a tabular form on a DB table. One of the columns is a date field. When the user hits the "add Row" button on the tabular form, I want the Date field to be defaulted to sysdate. Here is what I have tried so far,

      1. Created a "hidden" item P1_SYSDATE and populated the default value with sysdate. After this, under the DB tabular report date field, I used default type - Item/application on this page and entered P1_sYSDATE

      2. Instead of populating the default value of the P1_SYSDATE hidden item, I created a before regions process and added

      :P1_SYSDATE := sysdate

      and added P1_SYSDATE to default type of the tabular date field with default type as "ITem/application on this page.

      I get the error

      ORA-01790: expression must have same datatype as corresponding expression

      I tried to_Char(sysdate,'dd-mon-yyyy') and then converting it back to to_date. still no luck.

      I thought this would be a pretty straight forward thing. Any help please?


      Edited by: ryansun on Dec 2, 2012 9:53 PM

      Edited by: ryansun on Dec 2, 2012 9:58 PM