1 Reply Latest reply: Feb 28, 2013 4:27 PM by 994084 RSS

    running cacaoadm in 64 bit

    user189677
      Our installation was always Solaris. We are just starting to look at moving to RedHat Linux. When I try to start cacaoadm, it always fails and in the log for cacaoadm, it shows this:

      STDERR: thr#10 java.lang.UnsatisfiedLinkError: /app/sun/DS/11g/dsee7/ext/cacao_2/cacao2/private/lib/libcacao_cacao.so: libpam.so.0: cannot
      open shared object file: No such file or directory

      libpam.so.0 exists, it's just the 64 bit version so I'm assuming that's why the 32 bit version of the cacao can't find it.

      I can find the 64 bit version in /app/sun/DS/11g/dsee7/ext/cacao_2/cacao2/private/lib64/libcacao_cacao.so but I can't figure out how to get cacaoadm to start in 64 bit mode. Is there some command line option I should be using to force it that way? Or some environment variable I am missing?

      Sorry for the dumb questions, I'm not used to the RedHat way of things yet.

      Thanks

      Edited by: Sam D on Dec 3, 2012 1:16 PM

      Never mind. Found the bug on the support site about this. Having the 32 bit version of the pam module installed now.