4 Replies Latest reply: Dec 4, 2012 4:13 PM by Catch_22 RSS

    Oracle Linux Patching/Updates Impact on Oracle Database

    user10437903
      I have several questions regarding Oracle Linux patching and its impact on Oracle Database.

      3 node Cluster
      Operating System: Oracle Linux Release 5 update 2
      Kernel: 2.6.18-92.1.22.0.1.el5 x86_64 GNU/Linux
      Grid Infrastructure: Oracle Grid Infrastructure 11g Release 2 (11.2.0.2)
      Database: Oracle Database 11g Release 2 Enterprise Edition (11.2.0.2) with RAC option
      ASM with ASMLib is being used for Data and FRA.


      *1)* Given your at Oracle Linux Release 5 update 2, will applying only Security Patches require any changes to ASMLib, Oracle Grid Infrastructure and/or Oracle Database (software binaries, configuration etc.)?

      *2)* Given your at Oracle Linux Release 5 update 2, will applying Bug Fixes and Security Patches to Oracle Linux 5 update 2 require any changes to ASMLib, Oracle Grid Infrastructure and/or Oracle Database (software binaries, configuration etc.)?

      *3)* Given your updating from Oracle Linux Release 5 update 2 to Oracle Linux Release 5 update 8, will this require any changes to ASMLib, Oracle Grid Infrastructure and/or Oracle Database (software binaries, configuration etc.)?


      I would most whole heartedly appreciate if someone could answer the specific questions asked, inline if possible. Our System Administrator is preparing to perform some patching and as the DBA I'd like to be certain what changes I need to prepare for? I also have a single instance database setup with Oracle Restart. I don't know if this impacts the answers above.

      Thanks in advance.
        • 1. Re: Oracle Linux Patching/Updates Impact on Oracle Database
          Avi Miller-Oracle
          user10437903 wrote:
          *1)* Given your at Oracle Linux Release 5 update 2, will applying only Security Patches require any changes to ASMLib, Oracle Grid Infrastructure and/or Oracle Database (software binaries, configuration etc.)?
          Yes. If you're using ASMlib, you'll need to upgrade that along with the kernel when you're updating that. I believe they recommend relinking GI and Database binaries as well, but you'd want to check with the DB team on that. However, if you move to the Oracle UEK kernel, ASMlib is built into the kernel and you don't need to upgrade it separately.
          *2)* Given your at Oracle Linux Release 5 update 2, will applying Bug Fixes and Security Patches to Oracle Linux 5 update 2 require any changes to ASMLib, Oracle Grid Infrastructure and/or Oracle Database (software binaries, configuration etc.)?
          Yes, see above.
          *3)* Given your updating from Oracle Linux Release 5 update 2 to Oracle Linux Release 5 update 8, will this require any changes to ASMLib, Oracle Grid Infrastructure and/or Oracle Database (software binaries, configuration etc.)?
          Likewise.
          I would most whole heartedly appreciate if someone could answer the specific questions asked, inline if possible. Our System Administrator is preparing to perform some patching and as the DBA I'd like to be certain what changes I need to prepare for? I also have a single instance database setup with Oracle Restart. I don't know if this impacts the answers above.
          Test this on your test systems first before doing it on production and open an Upgrade SR with Oracle Support before you start.
          • 2. Re: Oracle Linux Patching/Updates Impact on Oracle Database
            Catch_22
            How do you plan to apply Oracle Linux security patches? As far as I'm aware the yum security plug-in does not work with the Oracle public yum repository and there is no really feasible way to automate and determine security related patches only, unless you setup Oracle Enterprise Manager Grid Control (11g) or Cloud (12c)  and have a subscription to Oracle ULN.

            If you upgrade your Oracle Linux to the latest available version using the public yum repository, all patches, including errata will be applied. You cannot apply patches and stay on a specific release version unless you have a subscription and appropriate yum repository access.

            As far as I'm aware there are no changes required to your Oracle database or ASM setup and configuration when updating the OS, provided the version of the Oracle database is supported for the specific OS version (ASM features like ADVM/ACFS are kernel version depending). Upgrading from one major release to another, such as upgrading Oracle Linux 5 to Oracle Linux 6 is not supported and will require upgrading the Oracle Database to 11.2.0.3. You can check the Oracle database certification matrix to determine which Oracle database release version is required for which OS version http://docs.oracle.com/cd/E11882_01/relnotes.112/e23558/toc.htm

            The relinking of Oracle Database binaries is a common practice when updating the OS. I do not think it is necessary under Linux. Oracle binaries are typically standalone applications, or use Oracle provided libraries, or in some cases use OS shared libraries, which does not require relinking of Oracle binaries. Upgrading the Oracle database software of course requires relinking.

            Edited by: Dude on Dec 4, 2012 2:09 PM
            • 3. Re: Oracle Linux Patching/Updates Impact on Oracle Database
              Avi Miller-Oracle
              Dude wrote:
              As far as I'm aware the yum security plug-in does not work with the Oracle public yum repository
              Yes, it does.
              • 4. Re: Oracle Linux Patching/Updates Impact on Oracle Database
                Catch_22
                You're right. It does. Sorry, I did not notice that the problem has been fixed :)

                Thread: yum-security plugin
                Re: yum-security plugin

                I corrected my previous reply.

                Edited by: Dude on Dec 4, 2012 2:10 PM