This discussion is archived
1 2 3 4 5 Previous Next 70 Replies Latest reply: Jan 21, 2013 8:52 AM by Hussein Sawwan-Oracle Go to original post RSS
  • 60. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    Please do not post the contents of MOS docs as this violates Oracle support agreement policy. <-- OK. Removed. Thanks.
    Thanks!
    Are you starting a new patch session? <-- Yes, refer pause already running patch and resume

    Please make sure that all env variables are set correct to R12 -- Issue "env" command to verify. <-- Checked. Correct to R12 env.
    According to the doc, you should skip the error and complete the upgrade then apply the patch.

    Thanks,
    Hussein
  • 61. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    WF001 Newbie
    Currently Being Moderated
    Thanks for the response. Now I found all worker are failed again....

    The adctrl output is follows :
    Restarted: file ar120recpl.sql on worker 2 for product ar username AR.
    FAILED: file ar120recpl.sql on worker 2 for product ar username AR.

    ATTENTION: All workers either have failed or are waiting:

    FAILED: file ar120recpl.sql on worker 1.
    FAILED: file ar120recpl.sql on worker 2.
    FAILED: file ar120recpl.sql on worker 3.
    FAILED: file ar120recpl.sql on worker 4.
    FAILED: file ar120recpl.sql on worker 5.
    FAILED: file ar120recpl.sql on worker 6.
    FAILED: file ar120recpl.sql on worker 7.
    FAILED: file ar120recpl.sql on worker 8.
    FAILED: file ar120recpl.sql on worker 9.
    FAILED: file ar120recpl.sql on worker 10.

    <adwork001.log>
    DECLARE
    *
    ERROR at line 1:
    ORA-01688: unable to extend table XLA.XLA_AE_LINES partition AR by 16 in
    tablespace APPS_TS_TX_DATA
    ORA-06512: at line 70

    <alert error log>
    Incremental checkpoint up to RBA [0x2361.b9c.0], current log tail at RBA [0x2361.cec.0]
    Mon Jan 14 15:00:57 2013
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    MMON Flush encountered SYSAUX out of space error(1691).
    MMON (emergency) purge of WR snapshots (32667) and older
    ...
    ORA-1688: unable to extend table XLA.XLA_AE_LINES partition AR by 16 in tablespace APPS_TS_TX_DATA
    ORA-1688: unable to extend table XLA.XLA_AE_LINES partition AR by 16 in tablespace APPS_TS_TX_DATA

    I've already add datafile to APPS_TS_TX_DATA (size 1M and autoextend on next 20M maxsize 2000M), but still failed again...

    Any idea what is the solution?

    Thanks in advance,

    Edited by: SamCH on 2013年1月13日 下午11:35
  • 62. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    SamCH wrote:
    Thanks for the response. Now I found all worker are failed again....

    The adctrl output is follows :
    Restarted: file ar120recpl.sql on worker 2 for product ar username AR.
    FAILED: file ar120recpl.sql on worker 2 for product ar username AR.

    ATTENTION: All workers either have failed or are waiting:

    FAILED: file ar120recpl.sql on worker 1.
    FAILED: file ar120recpl.sql on worker 2.
    FAILED: file ar120recpl.sql on worker 3.
    FAILED: file ar120recpl.sql on worker 4.
    FAILED: file ar120recpl.sql on worker 5.
    FAILED: file ar120recpl.sql on worker 6.
    FAILED: file ar120recpl.sql on worker 7.
    FAILED: file ar120recpl.sql on worker 8.
    FAILED: file ar120recpl.sql on worker 9.
    FAILED: file ar120recpl.sql on worker 10.

    <adwork001.log>
    DECLARE
    *
    ERROR at line 1:
    ORA-01688: unable to extend table XLA.XLA_AE_LINES partition AR by 16 in
    tablespace APPS_TS_TX_DATA
    ORA-06512: at line 70

    <alert error log>
    Incremental checkpoint up to RBA [0x2361.b9c.0], current log tail at RBA [0x2361.cec.0]
    Mon Jan 14 15:00:57 2013
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    ORA-1691: unable to extend lobsegment SYS.SYS_LOB0000465832C00004$$ by 128 in tablespace SYSAUX
    MMON Flush encountered SYSAUX out of space error(1691).
    MMON (emergency) purge of WR snapshots (32667) and older
    ...
    ORA-1688: unable to extend table XLA.XLA_AE_LINES partition AR by 16 in tablespace APPS_TS_TX_DATA
    ORA-1688: unable to extend table XLA.XLA_AE_LINES partition AR by 16 in tablespace APPS_TS_TX_DATA

    I've already add datafile to APPS_TS_TX_DATA (size 1M and autoextend on next 20M maxsize 2000M), but still failed again...

    Any idea what is the solution?

    Thanks in advance,

    Edited by: SamCH on 2013年1月13日 下午11:35
    Please see your duplicate post -- All adworkers failed (ORA-01688: unable to extend table...)

    Thanks,
    Hussein
  • 63. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    WF001 Newbie
    Currently Being Moderated
    Hi Hussein,

    Thanks for your replies.

    The merged AutoPatch(7303029 & 6678700) (upgrade patch driver) is complete and I found some invalid objects need to be fixed now...

    select release_name from apps.fnd_product_groups;
    RELEASE_NAME
    --------------------------------------------------
    12.1.1

    Then, As per upgrade document "Oracle EBS Upgrade Guide Release 11i to 12.1.1", the next step is apply latest product patches(required), but I am facing below issue :

    1) Can I apply the latest product patches in 12.1.3 not in 12.1.1? Is the following docs is enough?

    2) Refer EBS: R12.1 Oracle Financials Recommended Patch Collection (RPC) [ID 954704.1]
    - Do I need to apply "Product-Specific Recommended Patches" for CE,FA,CL,AP,AR,SLA at this moment or after upgraded to 12.1.3?
    e.g. Patch14374740:R12.CE.B

    3) Refer Oracle E-Business Suite Pre-install Patches Report [Video] [ID 1448102.1] -> Download & Open the "Pre-install Patches Report" (EBS_R12.1_Preinstall_2012_Nov_20.zip file)
    - When open the summary report(FIN), I found around 82 patches for AP,AR,CE,FUN,XLA,XLE modules, do I need to apply these all patches at this moment or after upgraded to 12.1.3? Any easily way to apply these patches or replacement (if need)?

    4) How to upgrade 12.1.1 to 12.1.3 and when to upgrade?

    Thanks
  • 64. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    1) Can I apply the latest product patches in 12.1.3 not in 12.1.1? Is the following docs is enough?
    Upgrade to 12.1.3 then apply the latest patches.
    2) Refer EBS: R12.1 Oracle Financials Recommended Patch Collection (RPC) [ID 954704.1]
    - Do I need to apply "Product-Specific Recommended Patches" for CE,FA,CL,AP,AR,SLA at this moment or after upgraded to 12.1.3?
    e.g. Patch14374740:R12.CE.B
    After you upgrade to 12.1.3
    3) Refer Oracle E-Business Suite Pre-install Patches Report [Video] [ID 1448102.1] -> Download & Open the "Pre-install Patches Report" (EBS_R12.1_Preinstall_2012_Nov_20.zip file)
    - When open the summary report(FIN), I found around 82 patches for AP,AR,CE,FUN,XLA,XLE modules, do I need to apply these all patches at this moment or after upgraded to 12.1.3? Any easily way to apply these patches or replacement (if need)?
    Run the tool again after you upgrade to 12.1.3 then apply the patches you get.
    4) How to upgrade 12.1.1 to 12.1.3 and when to upgrade?
    Upgrade now before applying any other patches/fixes -- https://blogs.oracle.com/stevenChan/entry/ebs_1213_available

    Thanks,
    Hussein
  • 65. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    WF001 Newbie
    Currently Being Moderated
    Hi Hussein,

    Thanks for your replies again.

    Refer the Upgrade Guide 11i to 12.1.1 (CH3-CH4), do I need to complete other steps such as "Reset init.ora parmeters" & "Configure and start server processes" before upgrade to 12.1.3 (apply patchset 12.1.3) ?

    Thanks in advance,
  • 66. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    SamCH wrote:
    Hi Hussein,

    Thanks for your replies again.

    Refer the Upgrade Guide 11i to 12.1.1 (CH3-CH4), do I need to complete other steps such as "Reset init.ora parmeters" & "Configure and start server processes" before upgrade to 12.1.3 (apply patchset 12.1.3) ?

    Thanks in advance,
    Those steps are required so you have to implement them after you upgrade to 12.1.1 and before you upgrade to 12.1.3

    Thanks,
    Hussein
  • 67. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    WF001 Newbie
    Currently Being Moderated
    Hi Hussein,

    I do really appreciate your help here.

    I am confused about the next step "Configure and start server processes".
    Can you please confirm the following steps are right ?

    1. Startup database by ORACLE DB user
    2. Disable the maintenance mode by APPLR12MGR user
    3. startup application services by APPLR12MGR user
    --> $INST_TOP/admin/scripts/adstrtal.sh apps/<appspassword>
    4. run rapidwiz by root user (Set Display)
    cd /stage12/startCD/Disk1/rapidwiz/
    ./rapidwiz
    5. Select "Upgrade to Oracle Applications Release 12.1.1"
    -> Select "Configure Upgraded Release 12.1.1 Instance"
    -> Select xml file (APPLR12MGR user-> echo $CONTEXT_FILE)
    ->On "Validate System Configuration" screen
    - Found the "Login Page" did not succeed
    - the "Login Page" error -> RW-50016: Error - {0} was not created

    6. If the "Validate System Configuration" passed
    Generate appsutil.zip file : perl <AD_TOP>/bin/admkappsutil.pl
    and copy & unzip the appsutil.zip file on database tier $ORACLE_HOME/.

    7. Run AutoConfig on the database tier nodes using adautocfg.sh.....
    8. Run AutoConfig on the application tier nodes using adautocfg.sh.....

    Thanks again~
  • 68. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    748906 wrote:
    Hi Hussein,

    I do really appreciate your help here.

    I am confused about the next step "Configure and start server processes".
    Can you please confirm the following steps are right ?

    1. Startup database by ORACLE DB user
    2. Disable the maintenance mode by APPLR12MGR user
    3. startup application services by APPLR12MGR user
    --> $INST_TOP/admin/scripts/adstrtal.sh apps/<appspassword>
    4. run rapidwiz by root user (Set Display)
    cd /stage12/startCD/Disk1/rapidwiz/
    ./rapidwiz
    5. Select "Upgrade to Oracle Applications Release 12.1.1"
    -> Select "Configure Upgraded Release 12.1.1 Instance"
    -> Select xml file (APPLR12MGR user-> echo $CONTEXT_FILE)
    ->On "Validate System Configuration" screen
    - Found the "Login Page" did not succeed
    - the "Login Page" error -> RW-50016: Error - {0} was not created

    6. If the "Validate System Configuration" passed
    Generate appsutil.zip file : perl <AD_TOP>/bin/admkappsutil.pl
    and copy & unzip the appsutil.zip file on database tier $ORACLE_HOME/.

    7. Run AutoConfig on the database tier nodes using adautocfg.sh.....
    8. Run AutoConfig on the application tier nodes using adautocfg.sh.....

    Thanks again~
    Your steps are correct.

    For RW-50016 error, please start the services using "adopmnctl.sh startall" and click retry -- Assuming the command complete successfully and all the services are up.

    Please also see:

    Upgrade 11i to R12.x : Post Rapidwiz Install Check fails for the Login Page with RW-50016 [ID 942600.1]
    Unable to login after Release 11i to Release 12 Upgrade - RW-50016: Error: - {0} was not created: [ID 473320.1]
    Rapidwiz RW-50016: Error: - {0} was not created [ID 559402.1]
    R 12.1.1: Fresh Install Rapidwiz POST Install check is failing for several checks with error RW-50016: Error: - {0} was not created [ID 850264.1]
    Upgraded Release 12.1 Instance is failing for logon - RW-50016: Error: - {0} was not created [ID 889031.1]
    R12 Upgrade: Upgrade File (Failed); RW-50016: Error: - database ORACLE_HOME environment file was not created [ID 470759.1]

    Thanks,
    Hussein
  • 69. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    WF001 Newbie
    Currently Being Moderated
    Hi Hussein,

    Thanks for your help, the RW-50016: Error is fixed by autoconfig.

    Refer DOC#393931.1. Now I want to apply OPatch 11.1.0.9.10 (Patch#6880880 that is prerequisites for patch9593176), but I found the problem as below.

    Logon APPLR12MGR User
    $java -version
    java version "1.6.0"
    Java(TM) SE Runtime Environment (build pap3260sr2-20080818_01(SR2))
    IBM J9 VM (build 2.4, J2RE 1.6.0 IBM J9 2.4 AIX ppc-32 jvmap3260-20080816_22093 (JIT enabled, AOT e
    nabled)
    J9VM - 20080816_022093_bHdSMr
    JIT - r9_20080721_1330ifx2
    GC - 20080724_AA)
    JCL - 20080808_02

    $which java
    /d02/oracle/$ORACLE_SID/apps/tech_st/10.1.3/appsutil/jdk/jre/bin/java

    cat $CONTEXT_FILE | grep ias_version
    -> <ias_version oa_var="s_ias_version">10.1.3.4.0</ias_version>

    But I found the APPLR12MGR user's ORACLE HOME is 10.1.2. Do I need also update OPatch in 10.1.3?
    echo $ORACLE_HOME ->/d02/oracle/$ORACLE_SID/apps/tech_st/10.1.2

    Then, I check the opatch version is 1.0.0.0.57 before apply the patch#6880880
    cd $ORACLE_HOME/OPatch
    ./opatch version
    OPatch Version: 1.0.0.0.57

    After applied the patch#6880880, "opatch version" command is giving the error.
    cd $ORACLE_HOME/OPatch
    ./opatch version
    class cannot be loaded: java.lang.UnsupportedClassVersionError: oracle/opatch/OPatch (Unsupported major.minor version 49.0) - java.lang.UnsupportedClassVersionError: oracle/opatch/OPatch (Unsupported major.minor version 49.0)
    OPatch failed with error code 1

    But if I try the following command that is ok. What's problem and any solution to fix it? Thanks again.
    ./opatch version –jre /d02/oracle/bpsac2/apps/tech_st/10.1.3/appsutil/jdk
    OPatch Version: 11.1.0.9.10
    OPatch succeeded.

    Edited by: SamCH on 2013年1月21日 上午2:19
  • 70. Re: Upgrade 11i (11.5.10.2) to R12 (12.1.3)
    Hussein Sawwan-Oracle Employee ACE
    Currently Being Moderated
    If you are applying a patch to 10.1.3 ORACLE_HOME then you need to update opatch under this ORACLE_HOME.

    For the error you get, please see these docs.

    Opatch Commands Fails With the Error "java.lang.UnsupportedClassVersionError" [ID 1451959.1]
    OPatch Error: Exception in thread "main" java.lang.UnsupportedClassVersionError: oracle/opatch [ID 731296.1]

    Thanks,
    Hussein
1 2 3 4 5 Previous Next

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points