2 Replies Latest reply on Dec 11, 2012 4:22 AM by P.D. Moorthy

    JPXImporter throwing an error in OAF Customization

      Hi All,

      I have customized ReqLinesNotificationsVO for a requirement to change the Requisition Notification. When I try to import the custom jpx file I am getting an error.

      JPXImporter Command:
      java oracle.jrad.tools.xml.importer.JPXImporter \
      $JAVA_TOP/xx01/oracle/apps/icx/por/wf/server/ChargeAccount.jpx \
      -username apps -password <apps_pwd> \
      -dbconnection "(DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=<host_name>)(PORT=<port>))(CONNECT_DATA=(SID=<sid>)))"

      Error Message:
      Exception in thread "main" java.lang.NullPointerException
      at oracle.jrad.tools.util.CommandLineProcessor.<init>(CommandLineProcessor.java:126)
      at oracle.jrad.tools.xml.importer.JPXImporter.main(JPXImporter.java:70)

      We are on R12.1.3. This is a multi-node RAC Database.
      Surprisingly this worked fine in one instance (clone of Production) and is not working when I run the JPXImporter command in Production.

      Any help with this issue is much appreciated.

        • 1. Re: JPXImporter throwing an error in OAF Customization
          Sushant Sharma

          Can you try importing the same jpx from your local system. Using command like this:


          • 2. Re: JPXImporter throwing an error in OAF Customization
            P.D. Moorthy
            Check whether you have the right privileges to run this command. Try asking the DBAs to run this command to check as the user you are using to import may not have the privileges to run the import.

            Also do a XML import through the local machine