1 2 3 4 Previous Next 58 Replies Latest reply: Jan 11, 2013 3:42 PM by Hussein Sawwan-Oracle Go to original post RSS
      • 15. Re: Moving EBS database to different node
        970261
        How do i correct the one that errored out
        Like when i run the report the migration error report

        AP AP_AE_LINES_N4 INDEX X
        ORA-12801: error signaled in parallel query server P000
        ORA-01652: unable to extend temp segment by 6250 in tablespace APPS_TS_TX_IDX

        AP AP_CHRG_ALLOCATIONS_U1 INDEX X
        ORA-12801: error signaled in parallel query server P002
        ORA-01652: unable to extend temp segment by 6250 in tablespace APPS_TS_TX_IDX

        APPLSYS FND_LOBS TABLE X
        ORA-01652: unable to extend temp segment by 6250 in tablespace APPS_TS_MEDIA

        BIL BIL_BI_NEW_FST_ID_U1 INDEX X

        FPA AW$FPAPJP TABLE PTN1
        ORA-14257: cannot move partition other than a Range or Hash partition

        GL GL_JE_LINES_N1 INDEX X
        ORA-12801: error signaled in parallel query server P001
        ORA-01652: unable to extend temp segment by 6250 in tablespace APPS_TS_TX_IDX


        I am more worried about FND_LOBS and FPA.AW$FPAPJP tables.
        I am following note How to Speed Up Index Creation on FND_LOBS by indexing Only FND_HELP Data [ID 397757.1]

        Some how the FND_LOBS table is not migrated yet so i think i have to wait to rebuild the CTX index correct ?

        What about FPA.AW$FPAPJP table ?

        Do i have to kick off the migration again for failed objects ? Will OATM pick up only the error out objects or everything ?
        • 16. Re: Moving EBS database to different node
          Hussein Sawwan-Oracle
          Please add more space to those tablespaces (for now).

          Please see (OATM Utility Fails To Move Table FPA.AW$FPAPJP with ORA-14257 cannot move partition other than a Range or Hash partition [ID 463456.1]).

          Thanks,
          Hussein
          • 17. Re: Moving EBS database to different node
            970261
            OATM complete
            Referring to 12iupgrade.pdf file from Oracle

            I have reached Installing 12.1.1 through rapidwiz.
            R12.1.1 installation is complete without any issue.

            Next step is to bring up the application and verify R12.1.1
            The listener is missing on $ORA_CONFIG_HOME/10.1.2/network/admin

            How do i create the listener.ora file ?
            • 18. Re: Moving EBS database to different node
              Hussein Sawwan-Oracle
              967258 wrote:
              OATM complete
              Referring to 12iupgrade.pdf file from Oracle

              I have reached Installing 12.1.1 through rapidwiz.
              R12.1.1 installation is complete without any issue.
              Is this the first run of Rapid Install or the second one? If it is the first run, then ignore this and proceed with the upgrade.
              Next step is to bring up the application and verify R12.1.1
              The listener is missing on $ORA_CONFIG_HOME/10.1.2/network/admin

              How do i create the listener.ora file ?
              If this is the second run of Rapid Install, then the listener.ora file should be created by Rapid Install for you. Source the application env file and issue "cd $TNS_ADMIN" and check the listener.ora file under that directory. You may also run AutoConfig and check then.

              Thanks,
              Hussein
              • 19. Re: Moving EBS database to different node
                970261
                I am upgrading the Application to 12.1.1 and at step Validate system configuration

                Only the Login page is erroring out

                Login Page
                checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_HTML/AppsLogin
                RW-50016: Error: - {0} was not created:
                File = {1}

                I read most of the metalink note for this error and nothing is related

                Interestingly i found that the application.log has the below error

                12/12/17 17:05:12.615 html: Servlet error
                java.lang.NoClassDefFoundError: Could not initialize class oracle.apps.fnd.sso.Utils
                at oracle.apps.fnd.sso.AppsLoginRedirect.AppsSetting(AppsLoginRedirect.java:116)
                at oracle.apps.fnd.sso.AppsLoginRedirect.init(AppsLoginRedirect.java:170)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.loadServlet(HttpApplication.java:2379)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.findServlet(HttpApplication.java:4830)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.findServlet(HttpApplication.java:4754)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.getRequestDispatcher(HttpApplication.java:2978)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:738)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.AJPRequestHandler.run(AJPRequestHandler.java:313)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.AJPRequestHandler.run(AJPRequestHandler.java:199)
                at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
                at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
                at java.lang.Thread.run(Thread.java:619)


                Not sure what this means
                • 20. Re: Moving EBS database to different node
                  Hussein Sawwan-Oracle
                  967258 wrote:
                  I am upgrading the Application to 12.1.1 and at step Validate system configuration

                  Only the Login page is erroring out

                  Login Page
                  checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_HTML/AppsLogin
                  RW-50016: Error: - {0} was not created:
                  File = {1}

                  I read most of the metalink note for this error and nothing is related

                  Interestingly i found that the application.log has the below error

                  12/12/17 17:05:12.615 html: Servlet error
                  java.lang.NoClassDefFoundError: Could not initialize class oracle.apps.fnd.sso.Utils
                  at oracle.apps.fnd.sso.AppsLoginRedirect.AppsSetting(AppsLoginRedirect.java:116)
                  at oracle.apps.fnd.sso.AppsLoginRedirect.init(AppsLoginRedirect.java:170)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.loadServlet(HttpApplication.java:2379)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.findServlet(HttpApplication.java:4830)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.findServlet(HttpApplication.java:4754)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpApplication.getRequestDispatcher(HttpApplication.java:2978)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpRequestHandler.doProcessRequest(HttpRequestHandler.java:738)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.HttpRequestHandler.processRequest(HttpRequestHandler.java:453)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.AJPRequestHandler.run(AJPRequestHandler.java:313)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].server.http.AJPRequestHandler.run(AJPRequestHandler.java:199)
                  at oracle.oc4j.network.ServerSocketReadHandler$SafeRunnable.run(ServerSocketReadHandler.java:260)
                  at com.evermind[Oracle Containers for J2EE 10g (10.1.3.4.0) ].util.ReleasableResourcePooledExecutor$MyWorker.run(ReleasableResourcePooledExecutor.java:303)
                  at java.lang.Thread.run(Thread.java:619)


                  Not sure what this means
                  Did you get this error when running Rapid Insta?

                  Please see these docs.

                  Unable to login after Release 11i to Release 12 Upgrade - RW-50016: Error: - {0} was not created: [ID 473320.1]
                  Upgraded Release 12.1 Instance is failing for logon - RW-50016: Error: - {0} was not created [ID 889031.1
                  R 12.1.1: Fresh Install Rapidwiz POST Install check is failing for several checks with error RW-50016: Error: - {0} was not created [ID 850264.1]
                  Rapidwiz fails with RW-50016: Error: - {0} was not created: File = {1} [ID 1491399.1]
                  R12 - Logon is not working, no error message is shown [ID 435550.1
                  Upgrade 11i to R12.x : Post Rapidwiz Install Check fails for the Login Page with RW-50016 [ID 942600.1]
                  R12 Rapidwiz Fails on Post Installation Tasks : RW-50016, Timed Out( 100000 ) [ID 437152.1]
                  Rapidwiz RW-50016: Error: - {0} was not created [ID 559402.1]

                  Thanks,
                  Hussein
                  • 21. Re: Moving EBS database to different node
                    970261
                    I am still stuck at Post Install checks using rapidwiz on R12.1.1
                    The login page is failing.

                    I have opened SR with severity 1 with Oracle since two days so far not a single good response.

                    The adconfig.log has this errors. We tried many options including removeserver and removesystem and ran autoconfig again. But not good.

                    Below is the error. I am ignoring the first error but the DBC file creation is failing.

                    Unique constraint error (00001) is OK if key already exists
                    java.sql.SQLException: ORA-01403: no data found
                    ORA-06512: at "APPS.FND_APP_SERVER_PKG", line 91
                    ORA-06512: at "APPS.FND_APP_SERVER_PKG", line 136
                    ORA-06512: at line 1
                    - Database error modifying the server

                    ADD call failed with exit code 1

                    Trying to update information ...


                    UPDATE call failed with exit code 1
                    Updating parameters: fnd_jdbc_buffer_min=1 fnd_jdbc_buffer_max=5 fnd_jdbc_buffer_decay_interval=300

                    Updating parameters: fnd_jdbc_buffer_decay_size=5 fnd_jdbc_usable_check=false fnd_jdbc_context_check=true

                    Updating parameters: fnd_jdbc_plsql_reset=false

                    DBC generation failed with exit code 1

                    Updating Server Security Authentication
                    java.sql.SQLException: Invalid number format for port number
                    Database connection to jdbc:oracle:thin:@host_name:port_number:database failed
                    Updating Server Security Authentication failed with exit code 1
                    adgendbc.sh exiting with status 1
                    ERRORCODE = 1 ERRORCODE_END
                    .end std out.

                    .end err out.
                    • 22. Re: Moving EBS database to different node
                      Hussein Sawwan-Oracle
                      The adconfig.log has this errors. We tried many options including removeserver and removesystem and ran autoconfig again. But not good.

                      Below is the error. I am ignoring the first error but the DBC file creation is failing.

                      Unique constraint error (00001) is OK if key already exists
                      java.sql.SQLException: ORA-01403: no data found
                      ORA-06512: at "APPS.FND_APP_SERVER_PKG", line 91
                      ORA-06512: at "APPS.FND_APP_SERVER_PKG", line 136
                      ORA-06512: at line 1
                      - Database error modifying the server

                      ADD call failed with exit code 1
                      Please clean FND_NODES table then run AutoConfig.

                      Adgendbc.sh : ORA-06512: at "APPS.FND_APP_SERVER_PKG", line 298 [ID 954165.1]
                      How to Clean Nonexistent Nodes or IP Addresses From FND_NODES [ID 260887.1]
                      Updating Server Security Authentication
                      java.sql.SQLException: Invalid number format for port number
                      Database connection to jdbc:oracle:thin:@host_name:port_number:database failed
                      Updating Server Security Authentication failed with exit code 1
                      adgendbc.sh exiting with status 1
                      ERRORCODE = 1 ERRORCODE_END
                      .end std out.
                      Thanks,
                      Hussein
                      • 23. Re: Moving EBS database to different node
                        970261
                        Ran autoconfig
                        Below is the output
                        SQL> select node_name from fnd_nodes;

                        NODE_NAME
                        ------------------------------
                        OFINAPQ
                        OFINDBQ


                        The authentication is still missing and adconfig.log has same error
                        • 24. Re: Moving EBS database to different node
                          Hussein Sawwan-Oracle
                          967258 wrote:
                          Ran autoconfig
                          Below is the output
                          SQL> select node_name from fnd_nodes;

                          NODE_NAME
                          ------------------------------
                          OFINAPQ
                          OFINDBQ


                          The authentication is still missing and adconfig.log has same error
                          Did you clean the table, commit, run AutoConfig on the database tier node then on the application tier node?

                          Do you have proper entry in the hosts file?

                          Thanks,
                          Hussein
                          • 25. Re: Moving EBS database to different node
                            EBSDBA
                            Hi,

                            Please check invalid objects in the database, specially FND_APP_SERVER_PKG

                            If there are any invalid objects, recompile them.

                            Thanks
                            • 26. Re: Moving EBS database to different node
                              970261
                              Yes i cleaned the table. Ran autoconfig on DB tier and then on application tier.

                              FND_APP_SERVER_PKG is valid also.

                              SQL> select object_name,object_type,owner from all_objects where status='INVALID';

                              OBJECT_NAME OBJECT_TYPE OWNER
                              ------------------------------ ------------------- ------------------------------
                              OKE_DELIVERABLE_UTILS_PUB PACKAGE BODY APPS
                              OKE_DELIVERABLE_UTILS_PKG PACKAGE BODY APPS
                              XA_GATEWAY_PKG PACKAGE BODY APPS
                              XXBN_PROJECT_ACTUAL_BUDGET_PKG PACKAGE BODY APPS
                              PEX_PO_PKG PACKAGE BODY APPS
                              CE_BANK_PURGINGS PACKAGE BODY APPS
                              HZ_IMP_LOAD_WRAPPER PACKAGE BODY APPS
                              AME_API5 PACKAGE BODY APPS
                              FND_OID_DIAG PACKAGE BODY APPS
                              BIL_BI_OPTY_MV_REFRESH_PKG PACKAGE BODY APPS
                              CS_WF_ACTIVITIES_PKG PACKAGE BODY APPS
                              POA_ITEMS_V VIEW APPS

                              Not sure what is causing to generate the DBC file

                              Because of that I am stuck at the rapidwiz screen on Post Install steps.
                              Also it will not allow me to move forward unless the login issue is resolved

                              Does the post install steps have to make sure that the autoconfig runs sucessfully ? Because i see that the DBC file is not populated and the listener.ora file was missing

                              Below is the log file contents for rapidwiz. Only the login page is failing. After seeing most of the notes i found out that the autoconfig did not run successfully.

                              DBC File
                              ---------
                              DBC file passes instantiated variables test:
                              File = /orappl_finapd/fint/inst/apps/FINT_ofinapq/appl/fnd/12.0.0/secure/FINT.dbc
                              HTTP
                              -------------
                              checking URL = http://ofinapq.hq.bn-corp.com:8002
                              HTTP Listener is responding
                              Help Page
                              ----------
                              checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_HTML/help
                              Page is responding
                              Virtual Directory
                              ------------------
                              checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_MEDIA/FNDLOGOL.gif
                              Page is responding
                              checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_JAVA/oracle/apps/fnd/admin/server/server.xml
                              Page is responding
                              checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_CGI/FNDWRR.exe
                              Page is responding
                              JSP
                              ----
                              checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_HTML/jtfTestCookie.jsp
                              JSP is responding

                              Login Page
                              -----------
                              checking URL = http://ofinapq.hq.bn-corp.com:8002/OA_HTML/AppsLogin
                              RW-50016: Error: - {0} was not created:
                              File = {1}
                              • 27. Re: Moving EBS database to different node
                                Hussein Sawwan-Oracle
                                What does your hosts file look like?

                                Thanks,
                                Hussein
                                • 28. Re: Moving EBS database to different node
                                  970261
                                  Application tier host file
                                  [appfint@ofinapq logs]$ cat /etc/hosts
                                  # Do not remove the following line, or various programs
                                  # that require network functionality will fail.
                                  127.0.0.1 localhost.localdomain localhost
                                  ##127.0.0.1 ofinapq.hq.bn-corp.com ofinapq localhost.localdomain localhost
                                  ##::1 localhost6.localdomain6 localhost6
                                  10.221.212.111 ofinapq.hq.bn-corp.com ofinapq
                                  10.221.212.110 ofindbq.hq.bn-corp.com ofindbq
                                  161.221.112.33 nimprd.hq.bn-corp.com nimprd

                                  Database tier host file

                                  [orafind@ofindbq 10.2.0.5]$ cat /etc/hosts
                                  # Do not remove the following line, or various programs
                                  # that require network functionality will fail.
                                  127.0.0.1 localhost.localdomain localhost
                                  ##127.0.0.1 ofindbq.hq.bn-corp.com ofindbq localhost.localdomain localhost
                                  ##::1 localhost6.localdomain6 localhost6
                                  10.221.212.110 ofindbq.hq.bn-corp.com ofindbq
                                  10.221.212.111 ofinapq.hq.bn-corp.com ofinapq
                                  • 29. Re: Moving EBS database to different node
                                    Hussein Sawwan-Oracle
                                    Your hosts file look fine.

                                    Can you please apply the latest AutoConfig and Rapid Clone patches and check then?

                                    Thanks,
                                    Hussein