This discussion is archived
5 Replies Latest reply: Jan 3, 2013 8:22 AM by 818785 RSS

SunFire V245 no "ok>" mode

28125 Newbie
Currently Being Moderated
Good evening everybody, I got a v245 server and get a problem:
I can log in sc, and i had tried all the commands of sc mode but to logging into ok mode
Some “print screens”
Connected power cables to both power outlets
SSH to the server over NET MGM and login as admin

sc> showplatform -v
SUNW,Sun-Fire-v245
Chassis Serial Number: XXXXXXX00X
Domain Status
------ ------
S0 OS Standby

sc> poweron
sc>
SC Alert: Host System has Reset
sc> showplatform -v
SUNW,Sun-Fire-v245
Chassis Serial Number: XXXXXXX00X
Domain Status
------ ------
S0 OS Reset

sc> showusers
username connection login time client IP addr console
-------- ---------- ---------- -------------- -------
auto serial JAN 01 21:28 system
admin ssh-1 JAN 01 21:28 10.10.0.8

but once i use "console -f" command It's just show "Enter #. to return to ALOM." and no “ok>” promt
sc> console -f
Warning: User <auto> currently has write permission to this console and forcibly removing them will terminate any current write actions and all work will be lost. Would you like to continue? [y/n]y
Enter #. to return to ALOM.

Any ideas what I have to do? All lights on the server are green
  • 1. Re: SunFire V245 no "ok>" mode
    bigdelboy Pro
    Currently Being Moderated
    The last time someone has this issue on the forum typing 'return' a couple of times (once should be enough?) brought up the 'ok' prompt.

    I accept you may have done that.


    After that at least two options may be possible:

    ... The machine has faulted and powered off .... you should be able to determine that back at the alom, ( actually the lights are green so that is probably not the case)
    ... auto-boot? was true and The machine has "hung" during the boot process


    good luck
  • 2. Re: SunFire V245 no "ok>" mode
    28125 Newbie
    Currently Being Moderated
    thank you for quick reply.

    1. Typed 'return' more than couple of times

    2. All lights are green

    3.
    sc> bootmode
    Bootmode: normal
    bootscript="setenv auto-boot? false"

    no console:-(
  • 3. Re: SunFire V245 no "ok>" mode
    Nik Expert
    Currently Being Moderated
    Hi.
    Check output of consolehistory

    Try reset nvram to default value as console can be redirected to other device.

    bootmode reset_nvram

    Regards.
  • 4. Re: SunFire V245 no "ok>" mode
    28125 Newbie
    Currently Being Moderated
    It is real mystery for me now

    sc> consolehistory
    sc>

    sc> bootmode
    Bootmode: reset_nvram
    Expires MON DEC 10 09:06:28 UTC 2012
    bootscript="setenv auto-boot? false"
    sc> poweroff
    Are you sure you want to power off the system [y/n]? y

    sc> poweron
    sc>
    SC Alert: Host System has Reset

    sc> console -f
    Enter #. to return to ALOM.

    pressed Enter multiple times
    same problem. blinking black box no "ok>"
  • 5. Re: SunFire V245 no "ok>" mode
    818785 Newbie
    Currently Being Moderated
    This could be caused because the console output is not directed to the ttya (Net MGM port), it could be redirected to ttyb (serial MGM port) or screen if the server has a video card, in order to fix this you should change the OBP variable "output-device" to ttyb instead of ttyb or screen, but as you are not able to reach an OK prompt you should use the ALOM "bootmode bootscript="setenv output-device ttya"" command

    bootmode bootscript="string"

    sc> bootmode bootscript="setenv output-device ttya"

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points