4 Replies Latest reply on Dec 12, 2012 2:05 PM by Fabian

    Universal Installer (OUI) failing on pre-requisites

    user5856470
      Could anyone had this issue before, or know what to do to get the Install gui open so I can get on with the install.

      i have copied the Oracle CD to a mount point on the relevant server and running the disk from there. The messages that appear when I run the runInstaller are below.

      Any ideas would be welcome....


      oracle@devux26 # pwd
      /disk0m1/app/oracle/software/OracleFR10g_90400Disk/INSTALL/SOLARIS

      oracle@devux26 # ./runInstaller
      Starting Oracle Universal Installer ...

      Checking requirements...

      Checking operating system version: must be 5.8 or 5.9.
      Actual 5.9 Passed

      Checking operating system packages: SUNWarc,SUNWbtool,SUNWhea,SUNWlibm,SUNWlibms,SUNWsprot,SUNWsprox,SUNWtoo,SUNWi1of,SUNWxwfnt,SUNWi1cs,SUNWi15cs Passed
      Checking swap space: must be greater than 1536 MB.
      Actual 9699MB Passed
      Checking Temp space: must be greater than 150 MB.
      Actual 9669 MB Passed

      All requirements met.

      Checking operating system patches: 113096-03,112785-26 Passed
      Checking for patch 113096-03; found 113096_03
      Checking for patch 112785-26; found 112785_54
      Checking if CPU speed is above 250 MHz.
      Actual 900 MHz Passed
      Checking monitor: must be configured to display at least 256 colors Failed <<<<

      Some optional pre-requisite checks have failed (see above). Continue? (y/n) [n] y
      Preparing to launch Oracle Universal Installer from /tmp/OraInstall2012-12-11_01-48-14PM. Please wait ...The Java RunTime Environment was not found at /tmp/OraInstall2012-12-11_01-48-14PM/jre/bin/java. Hence, the Oracle Universal Installer cannot be run.
      Please visit http://www.javasoft.com and install JRE version 1.3.1 or higher and try again.
      : No such file or directory
        • 1. Re: Universal Installer (OUI) not  failing on pre-requisites
          Fabian
          Hi,

          You Got the below Error,As Display is not set for your Solaris Box
          Checking monitor: must be configured to display at least 256 colors Failed <<<<
          Try the below 2 solutions

          1) set display for Your SOLARIS Box,Then Execute the ./runInstaller

          export DISPLAY=<ipaddress or hostname>:0.0
          echo $DISPLAY
          $>xclock
          $> ./runInstaller

          Follow the below link as well
          http://seasql.wordpress.com/2011/03/22/could-not-execute-auto-check-for-display-colors-using-command-usrbinxdpyinfo/

          Or
          2)Try executing the runinstaller script as follows
          *./runInstaller -ignoreSysPrereqs*

          In my Environment,We had downloaded Xmanager(third party free software), through this we were able to get GUI without any problem.

          Thanks and Regards
          Fabian
          • 2. Re: Universal Installer (OUI) not  failing on pre-requisites
            user5856470
            The usr/openwin/bin/xclock is helpful, to test the display works.

            Figured out the initial prereq error, just missed out the 0.0 at end of day.
            ie after starting hummingbird Exceed the unix command should be
            DISPLAY=<display ip address>:0.0
            export DISPLAY

            The initial prereq check is now working. However the main error about java 1.3.1 missing is still appearing as seen below!

            Checking monitor: must be configured to display at least 256 colors.
            Actual 16777216 Passed
            Preparing to launch Oracle Universal Installer from /tmp/OraInstall2012-12-12_12-42-56PM. Please wait ...The Java RunTime Environment was not found at /tmp/OraInstall2012-12-12_12-42-56PM/jre/bin/java. Hence, the Oracle Universal Installer cannot be run.
            Please visit http://www.javasoft.com and install JRE version 1.3.1 or higher and try again.
            : No such file or directory

            Edited by: user5856470 on Dec 12, 2012 5:04 AM
            • 3. Re: Universal Installer (OUI) not  failing on pre-requisites
              user5856470
              Resolved the java error.

              As with other cds you can copy the cd contents as is to the unix box and run from there.
              However this was the issue. After mounting the cd on the unix box (though at another site), for a start lower cased files were viewable (don't ask how), runInstaller file appeared (which could not be seen directly from cd on my PC) and any issues had were no more.

              Thanks for suggestions. Hope this helps others.

              Kind Regards,

              Mohammed

              Edited by: user5856470 on Dec 12, 2012 6:12 AM
              • 4. Re: Universal Installer (OUI) not  failing on pre-requisites
                Fabian
                Follow the metalink id,
                *When Trying To Start The Oracle Universal Installer (OUI), It Fails With The Error `The Java RunTime Environment was not found at /bin/java` [ID 312997.1]*

                There are many reason why u get "the java runtime environment was not found "

                Give a try to below solution
                1. Create a soft-link to any OS JRE installation or Install JRE seperately

                2. Invoke OUI as follows:
                $ORACLE_HOME/oui/bin/runInstaller -ignoreSysPrereqs -jreLoc <the_entire_path_to_OS_JRE>
                Regards
                FAbian
                1 person found this helpful