0 Replies Latest reply: Dec 11, 2012 9:18 AM by user160607 RSS

    Java web Application slowness issue

    user160607
      Hi,

      First of all, I am not able to determine whether it is a Java issue or weblogic issue or OS issue.
      We are in midst of a migration project which includes different technologies such as plain J2EE, Portal, OSB and Oracle ID products,etc..
      Old platform is Solaris/Sun JDK 5.0_32 bit/weblogic 9
      New platform is AIX/IBM J9JVM 6.0_64 bit/weblogic 10.3.5
      We have an app, call it Offer Management System (+OMS+) which takes a flat file as input, converts them into XML, validate the data and commit to Database.
      For validation function, it depend on another app called Cache Server which is nothing but another simple JEE app deployed on the same weblogic instance.
      The cache server does not use the weblogic port rather it uses it's own one to listen. The communication is over RMI, for OMS to reach Cache server.

      For a flat file of 100 offers, the offer processing takes about 80-110 seconds in new platform where in old platform it takes only 15-20 seconds.
      We are deploying the same ear files in old and new platform. We tried all our best to find why this slowness but succeeded. We do have have few screen shots taken 5 months back in the new platform indicating it indeed worked faster at that time. ( because the processing time is persisted in a DB column). But now we are able to get back to that old state. We setup the weblogic and applications in local laptop/windows and connected to the same database as that of our new AIX platform which also worked very fast, say 10 seconds only. We again tried a simple plain weblogic domain and server on AIX box and deployed the same EAR files which is also slow.
      The heap(1GB), perm and everything is same across all our setup.
      We have enabled logging (the OMS has inbuilt logging) up to Milli-seconds level. We observed that in AIX each java function/API process takes about 7 milli-sec where as in windows and Solaris, it takes just one milli-sec only. The time taken by OMS to retrieve data from cache also is high ( 1 milli-sec in Solaris and 5-8 milli-sec in AIX)

      The AIX boxes are latest/powerful/resourceful and we have about ten weblogic instances running there and all other are performing well.

      We really do not able to find out what causes the slowness for this OMS application in AIX platform.

      Can you please help us on how we can approach this issue. Please keep in mind on the communication nature between OMS and Cache Server

      Thanks & Rgds.