5 Replies Latest reply on Dec 13, 2012 9:16 PM by 708631

    Apex report styling

    708631
      I just installed the apex stand alone listener on a server, it is working and I can access a small document reporting application I made in apex over the network.
      But there is no styling on the page when I access over the network.
      If I access locally it looks great, i tried from multiple browsers over the network and there is no styling regardless of browser.

      after researching I found this is something with setting the /images folder to /i/ but im not sure how to do this.


      any ideas ?

      Edited by: Jay on Dec 13, 2012 9:23 AM
        • 1. Re: Apex report styling
          Keith Malay
          Jay,

          What OS are you running Oracle on?
          What version of Oracle (10g, 11g, etc)?
          What version of APEX (4.0, 4.1, etc)?
          Is APEX installed on a server? Or on your local PC?
          You mentioned the APEX Listener. How did you deploy the war file (Tomcat, WebLogic, etc)?


          R/,
          Keith Malay
          • 2. Re: Apex report styling
            708631
            keith,
            Windows 2003 server
            Oracle 10g
            Application Express 2.1.0.00.39

            Apex is installed on this server along with Oracle 10g.

            I installed the apex listener on this server also, i deployed the war file via this command.

            "%ProgramFiles%\Java\jdk1.6.0_20\bin\java" -jar "C:\Documents and Settings\user\Desktop\apexpatch2\apex.war"

            So from my local pc, across the network, I can access a small app in apex on the server by using the computer name like so :

            http://computername.domain.com:8080/apex/f?p=100:1:1965476839096971

            its accessable but it is not formatted at all, when i access the application on the server it looks great and is formatted.
            It looks like its not accessing the css /javascript files, i think this has to do with creating the i directory. I have tried this but am unsuccessful thus far.
            I tried this :

            "%ProgramFiles%\Java\jdk1.6.0_20\bin\java" -jar "C:\Documents and Settings\user\Desktop\apexpatch2\apex.war" static C:\etc\apex\apex /images

            then started the listener again, but not change.
            Please feel free to tell me if i am doing something completely wrong.
            thank you.
            • 3. Re: Apex report styling
              Keith Malay
              Jay,

              Try adding the explicit image path to the war deployment. Something like....

              *"%ProgramFiles%\Java\jdk1.6.0_20\bin\java" -Dapex.images="C:\etc\apex\apex\images" -jar "C:\Documents and Settings\user\Desktop\apexpatch2\apex.war"*

              Then test again from remote PC browser to check for images/styling.


              Keith Malay
              • 4. Re: Apex report styling
                708631
                Ok tried it.
                I shut down listener.
                Ran the command you provided. It started up the listener again.

                I accessed apex remotely, still the same issue. App is accessable but not formatted at all.Just a bunch of text on a blank page.
                • 5. Re: Apex report styling
                  708631
                  its working, i had to play around with the ports.

                  thanks