2 Replies Latest reply on Dec 27, 2012 11:36 AM by Bagagem

    Receive activity not receiving (relatively) large messages

      Hello everyone,

      I have a simple test composite with a long-running process (LongRunning_Process), which contains two receive activities followed by reply activities, like this:
      ReceiveFirst > ReplyFirst > ReceiveIntermediate > ReplyIntermediate
      They are all linked to a correlation set.
      The first receive activity is invoked by one other bpel process (BPELProcess1), synchronous, that is invoked via web service. The same applies for the second receive (invoked by the BPELProcess2).
      Each one is invoked by different bpel processes, which are triggered by different web services. However, it's used the same partner link with two operations.

      The input message of both receive activities (ReceiveFirst and ReceiveIntermediate) have elements with base64Binary content, and they tend to be a little large (about 100k characters, or more).

      In the first receive activity everything is ok, no matter the size of the message.
      The second receive activity, if the message has less than (lets say) 30k characters I can get the message as well. However, when it has more than that it only gets this:
        <part  name="payload">null</part> 
      I already have tried several things, still not successful...
      I think the implementation of the process is correct, because it works fine as long as the second message is relatively small...
      Any ideas on what's possibly wrong?

      The installed version is