2 Replies Latest reply: Dec 18, 2012 12:19 PM by 980343 RSS

    Failed to execute goal org.codehaus.mojo:jaxws-maven-plugin:1.10:wsimport

    980343
      Hi,

      As part of the project, few of the wsdl files needs to be parsed to Java file. For this jaxws-maven-plugin plugin is used. The Pom entry for the wsimport task is provided below.
      The problem is it is working fine in one system without any change in the POM and there is no much debug information in the root of the failure.

      The configuration is as below
      JDK 1.6 , Maven verion 2.2.1 , jaxws-maven-plugin 1.10


      <plugin>
      <groupId>org.codehaus.mojo</groupId>
      <artifactId>jaxws-maven-plugin</artifactId>
      <version>1.10</version>
      <executions>
      <execution>
      <goals>
      <goal>wsimport</goal>
      </goals>
      <configuration>
      <wsdlFiles>
      <wsdlFile>ShipService_v5.wsdl</wsdlFile>
      </wsdlFiles>
      <wsdlLocation>file:/C:/Users/.../Desktop/ShipService_v5.wsdl</wsdlLocation>
      <staleFile>${project.build.directory}/jaxws/stale/ShipService_v5.stale</staleFile>
      </configuration>
      <id>wsimport-generate-ShipService_v5</id>
      <phase>generate-sources</phase>
      </execution>
      </executions>


      The error report is as below

      [jaxws:wsimport]
      Processing: C:\Users\...\src\wsdl\ShipService_v5.wsdl
      jaxws:wsimport args: [-s, C:\Users\...\target\generated-sources\jaxws-wsimport, -d, C:\Users\...\target\classes, -verbose, -catalog, C:\Users\...\src\jax-ws-catalog.xml, -wsdllocation, file:/C:/Users/.../Desktop/ShipService_v5.wsdl, -extension, -Xnocompile, C:\Users\...\src\wsdl\ShipService_v5.wsdl]
      parsing WSDL...

      ------------------------------------------------------------------------
      BUILD FAILURE
      ------------------------------------------------------------------------

      ------------------------------------------------------------------------
      Failed to execute goal org.codehaus.mojo:jaxws-maven-plugin:1.10:wsimport (wsimport-generate-ShipService_v5) on project RPDataStreams: Error executing: wsimport [-s, C:\Users\...\target\generated-sources\jaxws-wsimport, -d, C:\Users\...\target\classes, -verbose, -catalog, C:\Users\...\src\jax-ws-catalog.xml, -wsdllocation, file:/C:/Users/.../Desktop/ShipService_v5.wsdl, -extension, -Xnocompile, C:\Users\...\src\wsdl\ShipService_v5.wsdl]

      This was ran using verbose as true and xdebug as true. But still the issue is not pin pointed.
      Any idea how to debug will be great help.