5 Replies Latest reply: Feb 5, 2013 9:56 AM by Scabo RSS

    Exporting from Discoverer Plus

    Scabo
      We have two different production Discoverer 11g servers, using different EULs on two different databases. When I do a supervised export from Discoverer Plus to Excel or another export format, the box that pops up to say the export is complete has a checkbox that says "Open the first exported sheet". On one of the servers, this works perfectly, and Excel (for example) opens right up and loads the spreadsheet. On the other, nothing happens, and you must go navigating through the file system to find the export file and open it manually.

      I cannot figure out why it works on the one server and not on the other. Local PC configuration seems unlikely to be responsible since I'm doing it all on the same PC. (And it is not just me--as far as I know all users experience the same behavior.) I don't see any user option settings that sound like they would affect this. There are a few differences in pref.txt between the two environments, but nothing that sounds related to this. Nor have I found anything relevant in the configuration documentation.

      Does anybody kmow what controls this?

      Thank you,
      Scott
        • 1. Re: Exporting from Discoverer Plus
          JB_JMU
          Hi,

          Have you had a look at Oracle Support Doc, 'Exporting To Excel From Discoverer Plus Does Not Automatically Open First Page After Export' [ID 250820.1] ?

          Thanks,
          Joy
          • 2. Re: Exporting from Discoverer Plus
            Scabo
            Thank you. I may have read that one before, but not recently. Unfortunately, it doesn't seem to be the answer. Both of our systems are addressed by machine name, not IP address. I tried adding both the machine name and the IP address to my Trusted Sites in IE, but it made no difference. Does make me wonder if it has something to do with firewall or VPN differences for the two systems though...

            Thanks again.

            Scott
            • 3. Re: Exporting from Discoverer Plus
              JB_JMU
              Hi again,

              We've also recently come across the following article: Unable to Export to XLS From Discoverer Plus 10.1.2 or 11g with JRE 1.6.0_23 or 1.6.0_24 [ID 1319218.1]
              This discusses installing a one-off patch for Bug 11711678 that can be applied to the latest version of Discoverer Plus. It might be worth investigating? Maybe your servers have different Java versions?

              Thanks,
              Joy
              • 4. Re: Exporting from Discoverer Plus
                Scabo
                I think you've hit it. I never thought to look at the Java Console, but it is showing exactly the symptom in the third bullet of the article. I've asked our DBA to look into the patch.

                Thanks!

                Scott
                • 5. Re: Exporting from Discoverer Plus
                  Scabo
                  Well, they had to create a new patch for us for some reason, but it looks like it has resolved the problem.

                  Thanks! Scott