This discussion is archived
8 Replies Latest reply: Dec 22, 2012 10:55 AM by ccortez RSS

could not find weutil folder in application server

user2040934 Newbie
Currently Being Moderated
Dear memebers,

I couldn't find the webutil folder in my Application server forms and reports services installation?

Now I want to configure the webutil.

Regards:
  • 1. Re: could not find weutil folder in application server
    MLBrown Journeyer
    Currently Being Moderated
    What version is your Application Server? According to the website: [url http://www.oracle.com/technetwork/developer-tools/forms/webutil-090641.html]Oracle Forms WebUtil  "Oracle WebUtil is delivered and installed as a component of the Oracle Developer Suite 10.1.2 and of Oracle Fusion Middleware 11g". If you are using an older version, then you would have to download it and install it yourself. You can find it at [url http://www.oracle.com/technetwork/developer-tools/forms/readme-082817.html]WebUtil Version 1.0.6 - and follow the instructions.

    Edited by: MLBrown on Dec 19, 2012 8:47 AM
  • 2. Re: could not find weutil folder in application server
    ccortez Journeyer
    Currently Being Moderated
    Hi,

    By default you will not find a webutil folder in ORACLE_HOME\forms directory, you have to create it.
    If you have access to MOS i recommend you to look for note 566628.1 "How To Install Webutil on 10.1.2.x Oracle Application Server" in order to install webutil correctly :)

    Regards
    Carlos
  • 3. Re: could not find weutil folder in application server
    user2040934 Newbie
    Currently Being Moderated
    Thanks dear,


    Application Server version: 10.1.2.0.2

    I configured the webutil according to the document,

    I can run the test form successfully but when try to open my application form using ?config=si it gives the following error:

    500 Internal Server Error
    Forms Servlet Error.
    Missing or invalid value for baseHTML parameter.
    Please check the servlet configuration to make sure this value specifies a valid file.

    I tried to disable the baseHTML parameter but the same error, only one time this parameter appear in formsweb.cfg

    I have the following webuti configration for [si]

    [si]
    envFile=default.env
    baseHTMLJInitiator=webutiljpi.htm
    jpi_download_page=http://java.sun.com/products/archive/j2se/1.4.2_09/index.html
    jpi_classid=clsid:CAFEEFAC-0016-0000-0010-ABCDEFFEDCBA
    jpi_codebase=http://java.sun.com/update/1.6.0/jinstall-6u10-windows-i586.cab#Version=6,0,10,33
    WebUtilArchive=frmwebutil.jar,jacob.jar,clientinfos.jar
    WebUtilLogging=off
    WebUtilLoggingDetail=normal
    WebUtilErrorMode=Alert
    WebUtilDispatchMonitorInterval=5
    WebUtilTrustInternal=true
    WebUtilMaxTransferSize=16384
    archive=frmall.jar,share.jar,laf_1012.jar
    #archive_jini=frmall_jinit.jar
    pageTitle=Store_Inventory
    form=login.fmx
    separateFrame=true
    lookandfeel=generic
    width=1024
    height=768
    workingDirectory=C:\ORA-APP\si
    userid=abc/abc@orcl

    Regards:
  • 4. Re: could not find weutil folder in application server
    ccortez Journeyer
    Currently Being Moderated
    Just add this paramter to your configuration:

    baseHTML=webutiljpi.htm

    and ensure that in [ORACLE_HOME]/forms/server you have the file webutiljpi.htm

    If someone's response is helpful or correct, please mark it accordingly :)

    Regards
    Carlos
  • 5. Re: could not find weutil folder in application server
    user2040934 Newbie
    Currently Being Moderated
    thanks for you reply,

    after all these changes, the error message changed:

    Frm-29101: there was a failure in the forms server during startup. this could due to invalid configuration
    please look into the web-server log file for details.

    Details ...
    java exception:

    ...

    this for ?config=si

    but when try for default forms/frmservlet

    Runtime error!
    program: c:\program files\internet explorer\iexplore.exe

    What's wrong with me?
  • 6. Re: could not find weutil folder in application server
    ccortez Journeyer
    Currently Being Moderated
    I recommend you to upgrade your oas from version 10.1.2.0.2 to 10.1.2.3 since that problem may be the result of a bug and may be fixed with this upgrade, and after that you should also apply bundle patch 9593176 so in resume:

    - apply patch to upgrade 10.1.2.3
    - apply bundle patch 9593176

    Regards
    Carlos
  • 7. Re: could not find weutil folder in application server
    user2040934 Newbie
    Currently Being Moderated
    dear Carlos,

    Thanks for you reply.

    I have installed only Forms and reports services, Can I upgrade this?

    from where can I download these?

    - apply patch to upgrade 10.1.2.3
    - apply bundle patch 9593176



    Regards:

    Muhammad

    Edited by: user2040934 on Dec 22, 2012 8:57 AM
  • 8. Re: could not find weutil folder in application server
    ccortez Journeyer
    Currently Being Moderated
    Hi Muhammad

    You must download them from My Oracle Support, you need to have an account for that, if you have it look for this numbers:

    patch for upgrade 10.1.2.3 -> 5983622
    bundle patch -> 9593176

    Regards
    Carlos

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points