This discussion is archived
4 Replies Latest reply: Mar 21, 2013 8:14 PM by bavani RSS

Error installing P6 Reporting Database 3.0

980904 Newbie
Currently Being Moderated
I am a relative noob when it comes to Oracle applications. And my customer has allowed their Oracle support contract to expire, which makes things so very easy....

I currently have EPPM 8.2 w/Weblogic and OBIEE installed and functional...11.1.1.5....on 2008 R2, with a Solaris backend. I am attempting to install and configure the P6 Reporting Database 3.0. I'm running into errors when running the staretl.bat process for the first time- I believe what is happening is it is trying to pull data into the Star database. It generates the following error:

*+<12.19.2012 16:50:04> staretl [INFO] (Progress) - Finished Script W_PROJECT_SECURITY_SS.sql+*
*+<12.19.2012 16:50:10> staretl [INFO] (Message) - Extract2Stage Insert Time for 825327 rows on table W_UDFVALUE_DS is .231 mins (13.85s) at rate 59590.397/s+*
*+<12.19.2012 16:50:10> staretl [INFO] (Message) - Complete extract on UDFVALUE for table W_UDFVALUE_DS rows=825327+*
*+<12.19.2012 16:50:10> staretl [INFO] (Message) - Processed 825327 rows in 13.857/s at rate of 59560.294/s+*
*+<12.19.2012 16:50:10> staretl [INFO] (Progress) - Finished Script W_UDFVALUE_DS.sql+*
*+<12.19.2012 16:50:10> staretl [ERROR] (Message) - The SQL script W_PROJECT_DS.sql failed+*
*+<12.19.2012 16:50:10> staretl [ERROR] (Message) - The SQL script W_ACTIVITY_DS.sql failed+*
*+<12.19.2012 16:50:10> staretl [ERROR] (Message) - The SQL script W_USER_SS.sql failed+*
*+<12.19.2012 16:50:10> staretl [ERROR] (Message) - The SQL script W_RESOURCE_DS.sql failed+*
*+<12.19.2012 16:50:10> staretl [ERROR] (Message) - The SQL script W_WBS_DS.sql failed+*
*+<12.19.2012 16:50:10> staretl [INFO] (Progress) - Step 12/28 Part 2/3 - FAILED (1) (0 hours, 0 minutes, 40 seconds, 16 milliseconds)+*

I can view those scripts that are referenced, but they don't mean much to me. The info I've posted is from the log files, so you can see how useless it is....when I spool and run one of them individually, to see what the exact errors are, here is what I get:

SQL> @ W_PROJECT_DS.sql*
ORA-06512: at "STARUSER.EXTRACT2STAGING", line 74*

Exception: Error during extract for table W_PROJECT_DS: ORA-00904: "LOCATION_ID": invalid i*

+(100,PROJECT,W_PROJECT_DS,n/a,n/a)+

BEGIN*
+*
ERROR at line 1:*
ORA-00904: "LOCATION_ID": invalid identifier*

ORA-06512: at "STARUSER.EXTRACT2STAGING", line 109*

ORA-06512: at line 2*

I don't pretend to know what the error means, or how I might correct it. Anyone have an idea of where I should start looking?

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points