This discussion is archived
6 Replies Latest reply: Dec 31, 2012 4:31 AM by ocpdev RSS

Calendar is not working.

ocpdev Newbie
Currently Being Moderated
Hi all,

I m migrating from Form6i to 11gr2 Forms on 64-bit Server 2008.

I have forms, which use calendar library. So I replaced my 6i calendar library file with 11g calendar library file only and nothing else, it compiled successfully.

But I pressed button, it does not display calendar, instead show following error:

FRM-40735 When-Button-Pressed trigger raised unhandled exception ORA-06508.

Is there any requirement of change its related things like proceedures,data block,canvas etc also ?

Please guide.

Thanks.
  • 1. Re: Calendar is not working.
    Andreas Weiden Guru
    Currently Being Moderated
    I would not exchange any library, i would simple recompile your own calendar library.
  • 2. Re: Calendar is not working.
    ocpdev Newbie
    Currently Being Moderated
    Thanks a lot Guru for a perfect answer.

    Sir, I have one more problem.

    I set my own path for Forms Runtime in by adding it in default.env. Its ok.

    But want same for Reports also, as it is not in default.env file.

    Please guide me.
  • 3. Re: Calendar is not working.
    Andreas Weiden Guru
    Currently Being Moderated
    When you create a reports-server, you also get a conf-file. This can either be accessed by filesystem or via the application-server-console. In that file there is a property source-dir. Put yout path into that property and restart the reports-server.
  • 4. Re: Calendar is not working.
    ocpdev Newbie
    Currently Being Moderated
    Thanks a lot Sir !

    You are great !

    Hoping your perfect guidance in future also!
  • 5. Re: Calendar is not working.
    Andreas Weiden Guru
    Currently Being Moderated
    You're welcome.
  • 6. Change Report11gr2 current path.
    ocpdev Newbie
    Currently Being Moderated
    Hi guru,
    Happy New Year !
    I m using Forms/Reports 11gr2 with followings:

    Weblogic 1036_generic.jar, JDK 6 - 64-bit, 11g r2 Database & Windows Server 2008 Ent 64-bit.

    I want to change reports deflault path, so that I could use my own path (like c:\finance), wherein I put all my reports.

    You advised me to put the path, in a parameter like *"sourceDir" value=C:\FINANCE in rwserver.conf* file of C:\Oracle\Middleware\asinst_1\config\ReportsServerComponent\RptSvr_hp_asinst_1 folder. But all in vein.

    Then I do the same in other rwserver.conf files of below folders also:

    C:\Oracle\Middleware\asinst_1\config\ReportsServerComponent\test_server.
    C:\Oracle\Middleware\user_projects\domains\ClassicDomain\config\fmwconfig\servers\WLS_REPORTS\applications\reports_11.1.2\configuration.
    C:\Oracle\Middleware\user_projects\domains\ClassicDomain\servers\WLS_REPORTS\tmp\_WL_user\reports_11.1.2\uxabaw\configuration.

    After this, one more problem arises i.e. when I call a report from a form, Report Server asks for Username & Password for System User Authentication, everytime I want to run the report.

    I have also post this query in the form, but couldn't get response till now, as it is urgent, so I decided to post you Guru.

    Please guide me again!

    Thanks & Regards.

    Edited by: ocpdev on Dec 31, 2012 5:57 PM

    Edited by: ocpdev on Dec 31, 2012 5:58 PM

    Edited by: ocpdev on Dec 31, 2012 6:00 PM

Legend

  • Correct Answers - 10 points
  • Helpful Answers - 5 points