2 Replies Latest reply: Jan 2, 2013 2:44 AM by Fabian RSS

    Running WebLogic on Solaris and attempting to create a Datasoruce

    952554
      Hi there:

      I have Weblogic version 10.3.4.0 running on Solaris box. I have Oracle Database 10g Express Edition Release 10.2.0.10 alreday installed on my local PC.
      I want to create a WebLogic datasource that points to my local pc where I have Oracle XE Universal. I believe there is nothing wrong doing that and it should work.
      To create the Datasource I used the following attributes:

      Name: XEDatabase
      JNDI Name:jdbc/XEDatabase
      DatabaseType: Oracle
      Database Driver: Oracle Driver (Thin XA) for Instance connections; Versions:9:0.1 and later
      Database name: XE
      Host Name: XXXXX my pc's IP address
      Port:1521
      Database user Name: sys
      Password: XXXXXXX

      Pinging from my PC to the unix box and visceversa works, therefore there is no firewall issues!

      While I attempt to create the Datasource and trying to test the connection I obtained the following error:

      Connection test failed.
      IO Error: The Network Adapter could not establish the connection
      oracle.jdbc.driver.T4CConnection.logon(T4CConnection.java:443)
      oracle.jdbc.driver.PhysicalConnection.<init>(PhysicalConnection.java:670)
      oracle.jdbc.driver.T4CConnection.<init>(T4CConnection.java:230)
      oracle.jdbc.driver.T4CDriverExtension.getConnection(T4CDriverExtension.java:34)
      oracle.jdbc.driver.OracleDriver.connect(OracleDriver.java:567)
      oracle.jdbc.pool.OracleDataSource.getPhysicalConnection(OracleDataSource.java:404)
      oracle.jdbc.xa.client.OracleXADataSource.getPooledConnection(OracleXADataSource.java:694)
      oracle.jdbc.xa.client.OracleXADataSource.getXAConnection(OracleXADataSource.java:267)
      oracle.jdbc.xa.client.OracleXADataSource.getXAConnection(OracleXADataSource.java:134)
      com.bea.console.utils.jdbc.JDBCUtils.testConnection(JDBCUtils.java:745)
      com.bea.console.actions.jdbc.datasources.createjdbcdatasource.CreateJDBCDataSource.testConnectionConfiguration(CreateJDBCDataSource.java:458)
      sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      java.lang.reflect.Method.invoke(Method.java:597)
      org.apache.beehive.netui.pageflow.FlowController.invokeActionMethod(FlowController.java:870)
      org.apache.beehive.netui.pageflow.FlowController.getActionMethodForward(FlowController.java:809)
      org.apache.beehive.netui.pageflow.FlowController.internalExecute(FlowController

      I suspect I amy not have the proper Oracle XE Unversal version loaded on my PC or something along those lines.

      Could I please have some ideas about this issue. Thanks!